summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-15 15:21:58 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-15 15:21:58 +0000
commit0dcdb70a1a76fb9e0487ab5a0b682957b2a3739a (patch)
treec10d0596de1577f9e4c9421a21cc5eb5a9364ad2 /sci-mathematics/rstudio
parentmultilib conversion wrt #459072 (diff)
downloadgentoo-2-0dcdb70a1a76fb9e0487ab5a0b682957b2a3739a.tar.gz
gentoo-2-0dcdb70a1a76fb9e0487ab5a0b682957b2a3739a.tar.bz2
gentoo-2-0dcdb70a1a76fb9e0487ab5a0b682957b2a3739a.zip
fix building with boost-1.53 wrt #476274
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-mathematics/rstudio')
-rw-r--r--sci-mathematics/rstudio/ChangeLog6
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.97.336-boost-1.53.patch64
-rw-r--r--sci-mathematics/rstudio/rstudio-0.97.336.ebuild5
3 files changed, 72 insertions, 3 deletions
diff --git a/sci-mathematics/rstudio/ChangeLog b/sci-mathematics/rstudio/ChangeLog
index 554728225ade..f6c19130564f 100644
--- a/sci-mathematics/rstudio/ChangeLog
+++ b/sci-mathematics/rstudio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/rstudio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rstudio/ChangeLog,v 1.5 2013/04/18 15:55:05 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rstudio/ChangeLog,v 1.6 2013/07/15 15:21:58 hasufell Exp $
+
+ 15 Jul 2013; Julian Ospald <hasufell@gentoo.org> rstudio-0.97.336.ebuild,
+ +files/rstudio-0.97.336-boost-1.53.patch:
+ fix building with boost-1.53 wrt #476274
*rstudio-0.97.336 (18 Apr 2013)
diff --git a/sci-mathematics/rstudio/files/rstudio-0.97.336-boost-1.53.patch b/sci-mathematics/rstudio/files/rstudio-0.97.336-boost-1.53.patch
new file mode 100644
index 000000000000..38bb63a8ab61
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.97.336-boost-1.53.patch
@@ -0,0 +1,64 @@
+=== modified file 'src/cpp/core/include/core/http/AsyncServer.hpp'
+--- src/cpp/core/include/core/http/AsyncServer.hpp 2013-07-09 12:02:58 +0000
++++ src/cpp/core/include/core/http/AsyncServer.hpp 2013-07-09 12:03:34 +0000
+@@ -264,7 +264,7 @@
+
+ // convert to cannonical HttpConnection
+ boost::shared_ptr<AsyncConnection> pAsyncConnection =
+- boost::shared_static_cast<AsyncConnection>(pConnection);
++ boost::static_pointer_cast<AsyncConnection>(pConnection);
+
+ // call the appropriate handler to generate a response
+ std::string uri = pRequest->uri();
+
+=== modified file 'src/cpp/core/include/core/http/LocalStreamAsyncClient.hpp'
+--- src/cpp/core/include/core/http/LocalStreamAsyncClient.hpp 2013-07-09 12:02:58 +0000
++++ src/cpp/core/include/core/http/LocalStreamAsyncClient.hpp 2013-07-09 12:03:36 +0000
+@@ -87,7 +87,7 @@
+ boost::shared_ptr<AsyncClient<boost::asio::local::stream_protocol::socket> >
+ ptrShared = shared_from_this();
+
+- return boost::shared_static_cast<LocalStreamAsyncClient>(ptrShared);
++ return boost::static_pointer_cast<LocalStreamAsyncClient>(ptrShared);
+ }
+
+ private:
+
+=== modified file 'src/cpp/core/include/core/http/TcpIpAsyncClient.hpp'
+--- src/cpp/core/include/core/http/TcpIpAsyncClient.hpp 2013-07-09 12:02:58 +0000
++++ src/cpp/core/include/core/http/TcpIpAsyncClient.hpp 2013-07-09 12:03:32 +0000
+@@ -74,7 +74,7 @@
+ boost::shared_ptr<AsyncClient<boost::asio::ip::tcp::socket> > ptrShared
+ = shared_from_this();
+
+- return boost::shared_static_cast<TcpIpAsyncClient>(ptrShared);
++ return boost::static_pointer_cast<TcpIpAsyncClient>(ptrShared);
+ }
+
+ private:
+
+=== modified file 'src/cpp/core/include/core/http/TcpIpAsyncClientSsl.hpp'
+--- src/cpp/core/include/core/http/TcpIpAsyncClientSsl.hpp 2013-07-09 12:02:58 +0000
++++ src/cpp/core/include/core/http/TcpIpAsyncClientSsl.hpp 2013-07-09 12:03:39 +0000
+@@ -109,7 +109,7 @@
+ boost::shared_ptr<AsyncClient<boost::asio::ssl::stream<boost::asio::ip::tcp::socket> > > ptrShared
+ = shared_from_this();
+
+- return boost::shared_static_cast<TcpIpAsyncClientSsl>(ptrShared);
++ return boost::static_pointer_cast<TcpIpAsyncClientSsl>(ptrShared);
+ }
+
+ virtual bool isShutdownError(const boost::system::error_code& ec)
+
+=== modified file 'src/cpp/session/http/SessionHttpConnectionListenerImpl.hpp'
+--- src/cpp/session/http/SessionHttpConnectionListenerImpl.hpp 2013-07-09 12:02:58 +0000
++++ src/cpp/session/http/SessionHttpConnectionListenerImpl.hpp 2013-07-09 12:03:29 +0000
+@@ -256,7 +256,7 @@
+ {
+ // convert to cannonical HttpConnection
+ boost::shared_ptr<HttpConnection> ptrHttpConnection =
+- boost::shared_static_cast<HttpConnection>(ptrConnection);
++ boost::static_pointer_cast<HttpConnection>(ptrConnection);
+
+ if (!authenticate(ptrHttpConnection))
+ {
diff --git a/sci-mathematics/rstudio/rstudio-0.97.336.ebuild b/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
index 8e37e161f4e6..1e9f90a5153a 100644
--- a/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rstudio/rstudio-0.97.336.ebuild,v 1.1 2013/04/18 15:55:05 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rstudio/rstudio-0.97.336.ebuild,v 1.2 2013/07/15 15:21:58 hasufell Exp $
EAPI=5
@@ -67,7 +67,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
- "${FILESDIR}"/${P}-linker_flags.patch
+ "${FILESDIR}"/${P}-linker_flags.patch \
+ "${FILESDIR}"/${P}-boost-1.53.patch
# Adding -DDISTRO_SHARE=... to append-flags breaks cmake so using
# this sed hack for now. ~RMH