summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-07-22 15:20:32 +0000
committerMike Gilbert <floppym@gentoo.org>2015-07-22 15:20:32 +0000
commitc8d0ef0831937c89831415afe4d59e20514f0d21 (patch)
treee86ea96029267e7535a7c8d26d28f321d36aeb2a /sys-apps/memtest86+
parentia64 stable wrt bug #541526 (diff)
downloadgentoo-2-c8d0ef0831937c89831415afe4d59e20514f0d21.tar.gz
gentoo-2-c8d0ef0831937c89831415afe4d59e20514f0d21.tar.bz2
gentoo-2-c8d0ef0831937c89831415afe4d59e20514f0d21.zip
Reapply grub.d changes that got reverted in last version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/ChangeLog7
-rw-r--r--sys-apps/memtest86+/memtest86+-5.01-r1.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index d3e2e202f5af..484563c1267c 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/memtest86+
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.70 2015/01/31 23:10:02 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.71 2015/07/22 15:20:32 floppym Exp $
+
+*memtest86+-5.01-r1 (22 Jul 2015)
+
+ 22 Jul 2015; Mike Gilbert <floppym@gentoo.org> +memtest86+-5.01-r1.ebuild:
+ Reapply grub.d changes that got reverted in last version bump.
31 Jan 2015; Andrew Savchenko <bircoph@gentoo.org> memtest86+-4.20-r1.ebuild,
memtest86+-4.20-r2.ebuild, memtest86+-5.01.ebuild:
diff --git a/sys-apps/memtest86+/memtest86+-5.01-r1.ebuild b/sys-apps/memtest86+/memtest86+-5.01-r1.ebuild
new file mode 100644
index 000000000000..c5b96eff818a
--- /dev/null
+++ b/sys-apps/memtest86+/memtest86+-5.01-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-5.01-r1.ebuild,v 1.1 2015/07/22 15:20:32 floppym Exp $
+
+EAPI=4
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="Memory tester based on memtest86"
+HOMEPAGE="http://www.memtest.org/"
+SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="floppy serial"
+
+BOOTDIR=/boot/memtest86plus
+QA_PRESTRIPPED="${BOOTDIR}/memtest.netbsd"
+QA_FLAGS_IGNORED="${BOOTDIR}/memtest.netbsd"
+
+RDEPEND="floppy? ( >=sys-boot/grub-0.95:0 sys-fs/mtools )"
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's,0x10000,0x100000,' memtest.lds || die
+ sed -e "s/scp memtest.bin root@192.168.0.12:\/srv\/tftp\/mt86plus//g" -i Makefile
+ epatch "${FILESDIR}/${P}-gcc-473.patch" \
+ "${FILESDIR}/${P}-hardcoded_cc.patch"
+
+ if use serial ; then
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h \
+ || die "sed failed"
+ fi
+
+ tc-export AS CC LD
+}
+
+src_test() { :; }
+
+src_install() {
+ insinto ${BOOTDIR}
+ newins memtest.bin memtest
+ newins memtest memtest.netbsd
+ dosym memtest ${BOOTDIR}/memtest.bin
+
+ exeinto /etc/grub.d
+ doexe "${FILESDIR}"/39_memtest86+
+
+ dodoc README README.build-process FAQ changelog
+
+ if use floppy ; then
+ dobin "${FILESDIR}"/make-memtest86+-boot-floppy
+ doman "${FILESDIR}"/make-memtest86+-boot-floppy.1
+ fi
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ elog
+ elog "memtest has been installed in ${BOOTDIR}/"
+ elog "You may wish to update your bootloader configs"
+ elog "by adding these lines:"
+ elog " - For grub2 just run grub-mkconfig, a configuration file is installed"
+ elog " as /etc/grub.d/39_${PN}"
+ elog " - For grub legacy: (replace '?' with correct numbers for your boot partition)"
+ elog " > title=${PN}"
+ elog " > root (hd?,?)"
+ elog " > kernel ${BOOTDIR}/memtest"
+ elog " - For lilo:"
+ elog " > image = ${BOOTDIR}/memtest"
+ elog " > label = ${PN}"
+ elog
+}