summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-12 07:54:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-12 07:54:14 +0000
commit0d6413475eeedfe2f5a40a487c2850c7b87a5e01 (patch)
treec72827006a252fd1d837d2637fc2ff3af196636a /sys-apps/pcsc-lite
parentQuery udev.pc pkg-config file for correct udevdir value. (diff)
downloadgentoo-2-0d6413475eeedfe2f5a40a487c2850c7b87a5e01.tar.gz
gentoo-2-0d6413475eeedfe2f5a40a487c2850c7b87a5e01.tar.bz2
gentoo-2-0d6413475eeedfe2f5a40a487c2850c7b87a5e01.zip
Query udev.pc pkg-config file for correct udevdir value.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog8
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.5-r1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 68e05ec3c09f..29998e322060 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.137 2012/08/04 14:22:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.138 2012/08/12 07:54:14 ssuominen Exp $
+
+*pcsc-lite-1.8.5-r1 (12 Aug 2012)
+
+ 12 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +pcsc-lite-1.8.5-r1.ebuild:
+ Query udev.pc pkg-config file for correct udevdir value.
*pcsc-lite-1.8.5 (04 Aug 2012)
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.5-r1.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..1e502e63afca
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.5-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.8.5-r1.ebuild,v 1.1 2012/08/12 07:54:14 ssuominen Exp $
+
+EAPI="4"
+
+inherit multilib eutils user toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="3741"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="libusb +udev"
+
+REQUIRED_USE="^^ ( udev libusb )"
+
+CDEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( sys-fs/udev )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<app-crypt/ccid-1.4.1-r1"
+
+pkg_setup() {
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /var/run/pcscd pcscd,openct
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --without-systemdsystemunitdir \
+ $(use_enable udev libudev) \
+ $(use_enable libusb) \
+ ${myconf}
+}
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/pcscd-init.5" pcscd
+
+ if use udev; then
+ local udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ insinto "${udevdir}"/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules; you only need to tell"
+ elog "the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}