summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-12-05 00:05:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-12-05 00:05:36 +0000
commitace52808b2615c76925170b9807958373b18c4ef (patch)
tree928aa66ce3ac223c5f039dfc964f4e01db02b5e4 /sys-apps/vbetool
parentSwitched from patches to sed for path changes w/ sed checks via function. Mov... (diff)
downloadgentoo-2-ace52808b2615c76925170b9807958373b18c4ef.tar.gz
gentoo-2-ace52808b2615c76925170b9807958373b18c4ef.tar.bz2
gentoo-2-ace52808b2615c76925170b9807958373b18c4ef.zip
Ubuntu has a 1.0 of this now. Please test a lot, the package itself seems to be a mess.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/ChangeLog8
-rw-r--r--sys-apps/vbetool/files/digest-vbetool-1.03
-rw-r--r--sys-apps/vbetool/vbetool-1.0.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-apps/vbetool/ChangeLog b/sys-apps/vbetool/ChangeLog
index b5a4e263da0b..e20248ce614c 100644
--- a/sys-apps/vbetool/ChangeLog
+++ b/sys-apps/vbetool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/vbetool
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.10 2007/08/14 21:21:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.11 2007/12/05 00:05:36 robbat2 Exp $
+
+*vbetool-1.0 (05 Dec 2007)
+
+ 05 Dec 2007; Robin H. Johnson <robbat2@gentoo.org> +vbetool-1.0.ebuild:
+ Ubuntu has a 1.0 of this now. Please test a lot, the package itself seems to
+ be a mess.
14 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org> vbetool-0.7.ebuild:
Added a --missing false since not all versions of pciutils support the zlib
diff --git a/sys-apps/vbetool/files/digest-vbetool-1.0 b/sys-apps/vbetool/files/digest-vbetool-1.0
new file mode 100644
index 000000000000..01327b164861
--- /dev/null
+++ b/sys-apps/vbetool/files/digest-vbetool-1.0
@@ -0,0 +1,3 @@
+MD5 e57b5475b8200e3c44df7f53f0fbdc72 vbetool_1.0-0ubuntu1.tar.gz 106319
+RMD160 00cf47c88af83d94bb3c7c1f72a25d07407d91f8 vbetool_1.0-0ubuntu1.tar.gz 106319
+SHA256 806985c853caf6ae5edd9075bb4f132d35de23c439e6d18fc1326e457858e0b9 vbetool_1.0-0ubuntu1.tar.gz 106319
diff --git a/sys-apps/vbetool/vbetool-1.0.ebuild b/sys-apps/vbetool/vbetool-1.0.ebuild
new file mode 100644
index 000000000000..949a00054c2d
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-1.0.ebuild,v 1.1 2007/12/05 00:05:36 robbat2 Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hardware state (i.e. reinitialize video card)"
+HOMEPAGE="http://www.srcf.ucam.org/~mjg59/vbetool/"
+#SRC_URI="${HOMEPAGE}${PN}_${PV}.orig.tar.gz"
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P//-/_}-1.tar.gz"
+#SRC_URI="http://www.srcf.ucam.org/~mjg59/${PN}/${P//-/_}-1.tar.gz"
+SRC_URI="http://archive.ubuntu.com/ubuntu/pool/main/${PN:0:1}/${PN}/${P//-/_}-0ubuntu1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-libs/zlib
+ sys-apps/pciutils
+ dev-libs/libx86"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ #epatch ${FILESDIR}/${P}-pci-compile-fix.patch
+ sed -i \
+ -e '/vbetool_LDADD/s,$(libdir)/libpci.a,-lpci,' \
+ "${S}/Makefile.am"
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-x86emu || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc LRMI
+}