summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 21:21:48 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 21:21:48 +0000
commitd9656ab854ae034ca08bb16ed6e3cbcf540c6b10 (patch)
tree044e2801ec70278f563b4024e38c141a736f5e41 /sys-apps/vbetool
parentAdded a --missing false since not all versions of pciutils support the zlib U... (diff)
downloadgentoo-2-d9656ab854ae034ca08bb16ed6e3cbcf540c6b10.tar.gz
gentoo-2-d9656ab854ae034ca08bb16ed6e3cbcf540c6b10.tar.bz2
gentoo-2-d9656ab854ae034ca08bb16ed6e3cbcf540c6b10.zip
Added a --missing false since not all versions of pciutils support the zlib USE flag. This was reported to bug #188221 by Åsmund Grammeltvedt <asmundg@big-oil.org>.
(Portage version: 2.1.3.3)
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/ChangeLog7
-rw-r--r--sys-apps/vbetool/vbetool-0.7.ebuild4
2 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/vbetool/ChangeLog b/sys-apps/vbetool/ChangeLog
index efda132fe3a4..b5a4e263da0b 100644
--- a/sys-apps/vbetool/ChangeLog
+++ b/sys-apps/vbetool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/vbetool
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.9 2007/06/22 17:59:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.10 2007/08/14 21:21:48 wolf31o2 Exp $
+
+ 14 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org> vbetool-0.7.ebuild:
+ Added a --missing false since not all versions of pciutils support the zlib
+ USE flag. This was reported to bug #188221 by Åsmund Grammeltvedt
+ <asmundg@big-oil.org>.
22 Jun 2007; Chris Gianelloni <wolf31o2@gentoo.org> vbetool-0.7.ebuild:
Added USE=zlib and a check on sys-apps/pciutils so we'll link with zlib when
diff --git a/sys-apps/vbetool/vbetool-0.7.ebuild b/sys-apps/vbetool/vbetool-0.7.ebuild
index b91460836034..9f6e8f730ced 100644
--- a/sys-apps/vbetool/vbetool-0.7.ebuild
+++ b/sys-apps/vbetool/vbetool-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-0.7.ebuild,v 1.2 2007/06/22 17:59:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-0.7.ebuild,v 1.3 2007/08/14 21:21:48 wolf31o2 Exp $
inherit eutils flag-o-matic
@@ -26,7 +26,7 @@ src_compile() {
if use zlib
then
append-ldflags -lz
- elif built_with_use sys-apps/pciutils zlib
+ elif built_with_use --missing false sys-apps/pciutils zlib
then
die "You need to build with USE=zlib to match sys-apps/pcituils"
fi