summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-05 04:55:05 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-05 04:55:05 +0000
commit57f37ad45e3403c39d06c9570ec47e2a0e17216e (patch)
treeedeb995e62e9340abd24b9e8251cf318f1235d40 /sys-apps
parentAdd yelp dependency (diff)
downloadgentoo-2-57f37ad45e3403c39d06c9570ec47e2a0e17216e.tar.gz
gentoo-2-57f37ad45e3403c39d06c9570ec47e2a0e17216e.tar.bz2
gentoo-2-57f37ad45e3403c39d06c9570ec47e2a0e17216e.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/sandbox-1.3.9.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 67a0208db110..6e7d3fc3dc6e 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.105 2009/02/20 06:57:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.106 2009/03/05 04:55:05 vapier Exp $
+
+*sandbox-1.3.9 (05 Mar 2009)
+
+ 05 Mar 2009; Mike Frysinger <vapier@gentoo.org> +sandbox-1.3.9.ebuild:
+ Version bump.
*sandbox-1.3.8 (20 Feb 2009)
diff --git a/sys-apps/sandbox/sandbox-1.3.9.ebuild b/sys-apps/sandbox/sandbox-1.3.9.ebuild
new file mode 100644
index 000000000000..0a94b38898be
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.3.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.3.9.ebuild,v 1.1 2009/03/05 04:55:05 vapier Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/lzma-utils"
+RDEPEND=""
+
+EMULTILIB_PKG="true"
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ mkdir "${WORKDIR}/build-${ABI}"
+ cd "${WORKDIR}/build-${ABI}"
+
+ multilib_toolchain_setup ${ABI}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf ${myconf} || die
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || die
+ done
+ ABI=${OABI}
+}
+
+src_test() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Checking sandbox for ABI=${ABI}..."
+ emake check || die "make check failed for ${ABI}"
+ done
+ ABI=${OABI}
+}
+
+src_install() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ emake DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage "${D}"/var/log/sandbox
+ chmod 0770 "${D}"/var/log/sandbox
+
+ local old=$(find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
+ if [[ -n ${old} ]] ; then
+ elog "Removing old sandbox libraries for you:"
+ elog ${old//${ROOT}}
+ find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -exec rm -fv {} \;
+ fi
+}