summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-18 06:19:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-18 06:19:22 +0000
commit01c3d8932977e04584e78c1728a29a5884180e87 (patch)
treed3bc481dc9a1f635049ace3bea21afdf4b8c1164 /sys-block/qla-fc-firmware
parentadded missing src_install() so that package installs files (diff)
downloadgentoo-2-01c3d8932977e04584e78c1728a29a5884180e87.tar.gz
gentoo-2-01c3d8932977e04584e78c1728a29a5884180e87.tar.bz2
gentoo-2-01c3d8932977e04584e78c1728a29a5884180e87.zip
Do not use the MID/MIDX firmware by default. It sucks compared to IP/IPX firmware.
(Portage version: 2.1.5.5)
Diffstat (limited to 'sys-block/qla-fc-firmware')
-rw-r--r--sys-block/qla-fc-firmware/ChangeLog9
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-block/qla-fc-firmware/ChangeLog b/sys-block/qla-fc-firmware/ChangeLog
index ecbeb55b556c..8505401aa8cf 100644
--- a/sys-block/qla-fc-firmware/ChangeLog
+++ b/sys-block/qla-fc-firmware/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/qla-fc-firmware
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/ChangeLog,v 1.16 2008/03/30 02:51:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/ChangeLog,v 1.17 2008/06/18 06:19:22 robbat2 Exp $
+
+*qla-fc-firmware-20071207-r1 (18 Jun 2008)
+
+ 18 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +qla-fc-firmware-20071207-r1.ebuild:
+ Do not use the MID/MIDX firmware by default. It sucks compared to IP/IPX
+ firmware.
30 Mar 2008; Robin H. Johnson <robbat2@gentoo.org>
qla-fc-firmware-20071207.ebuild:
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild
new file mode 100644
index 000000000000..df6a49c28288
--- /dev/null
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild,v 1.1 2008/06/18 06:19:22 robbat2 Exp $
+
+DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
+HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="qlogic-fibre-channel-firmware"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# really depends on absolutely nothing
+DEPEND=""
+RDEPEND=""
+
+FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
+
+src_install() {
+ # We must install this, say QLogic's people.
+ # They have claimed to me that the /license/ directory isn't sufficient, as
+ # there is no guarantee it will be on a system - and it would not be in any
+ # binpkg either. If you do something else with the firmware blobs, you are
+ # thus strongly encouraged to keep a copy of the LICENSE file with them on
+ # the system.
+ dodoc LICENSE
+ dodoc README.* CURRENT_VERSIONS
+ insinto /lib/firmware
+ # some older firmware are always provided by upstream
+ # for reasons documented in CURRENT_VERSIONS.
+
+ # Please see README.* as to why we do not use the MID/MIDX versions by
+ # default if they are newer.
+ # TODO: Provide a means to get them for people that really want them.
+ for f in ${FW_BASENAME} ; do
+ doins ${f}.*
+ latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
+ dosym ${latest_f} /lib/firmware/${f}
+ done
+}