summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-09 18:48:42 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-09 18:48:42 +0000
commitbed9adaffa0e2fecf3f9445f03058375abe371f4 (patch)
treeb2404658d0638dd63cdc66be5634a07af1bf6b0b /sys-block
parentWork around upstream bug, [-X] does not work. (diff)
downloadgentoo-2-bed9adaffa0e2fecf3f9445f03058375abe371f4.tar.gz
gentoo-2-bed9adaffa0e2fecf3f9445f03058375abe371f4.tar.bz2
gentoo-2-bed9adaffa0e2fecf3f9445f03058375abe371f4.zip
Bump up to latest snapshot from upstream mercurial tree (latest release did not work). Approved by robbat2.
(Portage version: 2.2.0_alpha90_p1/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/seekwatcher/ChangeLog12
-rw-r--r--sys-block/seekwatcher/files/seekwatcher-0.12_p20091015-dash-fix.patch26
-rw-r--r--sys-block/seekwatcher/seekwatcher-0.12_p20091015.ebuild45
3 files changed, 81 insertions, 2 deletions
diff --git a/sys-block/seekwatcher/ChangeLog b/sys-block/seekwatcher/ChangeLog
index 668c1cafac09..72c7c5144e9c 100644
--- a/sys-block/seekwatcher/ChangeLog
+++ b/sys-block/seekwatcher/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-block/seekwatcher
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/seekwatcher/ChangeLog,v 1.7 2009/11/04 08:23:42 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/seekwatcher/ChangeLog,v 1.8 2012/03/09 18:48:42 slyfox Exp $
+
+*seekwatcher-0.12_p20091015 (09 Mar 2012)
+
+ 09 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/seekwatcher-0.12_p20091015-dash-fix.patch,
+ +seekwatcher-0.12_p20091015.ebuild:
+ Bump up to latest snapshot from upstream mercurial tree (latest release did
+ not work). Approved by robbat2.
*seekwatcher-0.12 (04 Nov 2009)
diff --git a/sys-block/seekwatcher/files/seekwatcher-0.12_p20091015-dash-fix.patch b/sys-block/seekwatcher/files/seekwatcher-0.12_p20091015-dash-fix.patch
new file mode 100644
index 000000000000..0742fb9d5dff
--- /dev/null
+++ b/sys-block/seekwatcher/files/seekwatcher-0.12_p20091015-dash-fix.patch
@@ -0,0 +1,26 @@
+commit e594df5c73ab550fb76895f75f71109eb3640c41
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Thu Feb 23 22:28:28 2012 +0300
+
+ seekwatcher: fix failure when /bin/sh points to dash
+
+ Before the patch:
+ $ ./seekwatcher -t test.trace -o test.png -p 'sleep 5' -d /dev/sda2
+ > using tracefile ./test.trace
+ > sh: Syntax error: Bad fd number
+ > Empty blktrace run found, exiting
+
+Upstream status: sent, not applied yet
+diff --git a/cmd/seekwatcher b/cmd/seekwatcher
+index 7e96bd2..23cba1c 100755
+--- a/cmd/seekwatcher
++++ b/cmd/seekwatcher
+@@ -610,7 +610,7 @@ def run_blkparse(trace):
+ print "using tracefile %s" % os.path.join(trace_dir, x)
+ fh = tempfile.NamedTemporaryFile(dir=".")
+ os.system('blkparse -q -D ' + trace_dir + ' -i ' + x +
+- ' -d ' + fh.name + ' -O >& /dev/null')
++ ' -d ' + fh.name + ' -O > /dev/null 2>&1')
+ loaddata(fh, rd)
+ return rd
+
diff --git a/sys-block/seekwatcher/seekwatcher-0.12_p20091015.ebuild b/sys-block/seekwatcher/seekwatcher-0.12_p20091015.ebuild
new file mode 100644
index 000000000000..e0c840f088bb
--- /dev/null
+++ b/sys-block/seekwatcher/seekwatcher-0.12_p20091015.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/seekwatcher/seekwatcher-0.12_p20091015.ebuild,v 1.1 2012/03/09 18:48:42 slyfox Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit eutils distutils
+
+DESCRIPTION="Seekwatcher generates graphs from blktrace runs to help visualize IO patterns and performance."
+HOMEPAGE="http://oss.oracle.com/~mason/seekwatcher/"
+#SRC_URI="http://oss.oracle.com/~mason/seekwatcher/${P}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~slyfox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyrex"
+RDEPEND="dev-python/matplotlib
+ dev-python/numpy
+ >=sys-block/btrace-0.0.20070730162628"
+
+S=${WORKDIR}/${PN}-b392aeaf693b # hg snapshot
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dash-fix.patch
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "If you want to generate IO-movies from captured data, you must"
+ elog "install at least one of the following packages:"
+ elog "- media-video/mplayer with USE=encode"
+ elog "- media-libs/libtheora with USE=examples"
+}