summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2008-05-23 07:07:04 +0000
committerMarkus Rothe <corsair@gentoo.org>2008-05-23 07:07:04 +0000
commit46635eb571ae240cfdf250e8e8f010703b5cbe33 (patch)
tree2930203cd15f3b90af8919653beadfd7d9f6bada /sys-boot/yaboot-static
parent- Keyworded ~amd64 (diff)
downloadgentoo-2-46635eb571ae240cfdf250e8e8f010703b5cbe33.tar.gz
gentoo-2-46635eb571ae240cfdf250e8e8f010703b5cbe33.tar.bz2
gentoo-2-46635eb571ae240cfdf250e8e8f010703b5cbe33.zip
Fix variable quoting "${WORKDIR}/*" is not equal to "${WORKDIR}"/*. Add some die traps to the mv and cp commands. The current ebuild didn't install anything...
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/yaboot-static')
-rw-r--r--sys-boot/yaboot-static/ChangeLog8
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild7
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-boot/yaboot-static/ChangeLog b/sys-boot/yaboot-static/ChangeLog
index f0887cb03782..6ad85ec0e30e 100644
--- a/sys-boot/yaboot-static/ChangeLog
+++ b/sys-boot/yaboot-static/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/yaboot-static
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.19 2008/05/13 23:41:15 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.20 2008/05/23 07:07:04 corsair Exp $
+
+ 23 May 2008; Markus Rothe <corsair@gentoo.org>
+ yaboot-static-1.3.14.ebuild:
+ Fix variable quoting: "${WORKDIR}/*" is not equal to "${WORKDIR}"/*. Add
+ some die traps to the mv and cp commands. The current ebuild didn't install
+ anything...
13 May 2008; Joseph Jezak <josejx@gentoo.org>
-files/ofpath_device-tree_check.patch, -yaboot-static-1.3.12.ebuild,
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild
index ee0ed79dcfbe..a4f6a081b081 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild,v 1.3 2008/05/13 23:41:15 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild,v 1.4 2008/05/23 07:07:04 corsair Exp $
inherit eutils
@@ -21,6 +21,7 @@ PROVIDE="virtual/bootloader"
src_install() {
# don't blow away the user's old conf file
- mv "${WORKDIR}/etc/yaboot.conf" "${WORKDIR}/etc/yaboot.conf.unconfigured"
- cp -pPR "${WORKDIR}/*" "${D}/"
+ mv "${WORKDIR}/etc/yaboot.conf" "${WORKDIR}/etc/yaboot.conf.unconfigured" \
+ || die "mv failed"
+ cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
}