summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-06 04:03:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-06 04:03:50 +0000
commitd318f38bbcb1a217f807fb1b9fcd77b4d9998796 (patch)
treeb3d306e041182e7e2953b612bd243c7493ce7c6e /sys-boot
parentold (diff)
downloadgentoo-2-d318f38bbcb1a217f807fb1b9fcd77b4d9998796.tar.gz
gentoo-2-d318f38bbcb1a217f807fb1b9fcd77b4d9998796.tar.bz2
gentoo-2-d318f38bbcb1a217f807fb1b9fcd77b4d9998796.zip
Fix building with newer binutils and clean up the src_install to use Gentoo style install.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog11
-rw-r--r--sys-boot/elilo/elilo-3.4-r2.ebuild58
-rw-r--r--sys-boot/elilo/files/digest-elilo-3.4-r21
-rw-r--r--sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch15
4 files changed, 83 insertions, 2 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index a10bfec38ba9..4f7dbd1c6fcf 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/elilo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.8 2005/03/30 19:50:57 plasmaroo Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.9 2005/05/06 04:03:50 vapier Exp $
+
+*elilo-3.4-r2 (06 May 2005)
+
+ 06 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/elilo-3.4-proc-sigsetjmp.patch, +elilo-3.4-r2.ebuild:
+ Fix building with newer binutils and clean up the src_install to use Gentoo
+ style install.
*elilo-3.4-r1 (30 Mar 2005)
diff --git a/sys-boot/elilo/elilo-3.4-r2.ebuild b/sys-boot/elilo/elilo-3.4-r2.ebuild
new file mode 100644
index 000000000000..c6bbc5524500
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.4-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r2.ebuild,v 1.1 2005/05/06 04:03:50 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/elilo-3.4-makefile.patch
+ epatch "${FILESDIR}"/elilo-3.4-proc-sigsetjmp.patch
+ epatch "${FILESDIR}"/elilo-3.3a-devscheme.patch
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ newsbin "${FILESDIR}"/elilo-${PV} elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ if [[ ! -e ${D}/etc/elilo.conf ]] ; then
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+ fi
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ newman "${FILESDIR}"/elilo.8-${PV} elilo.8
+ newman "${FILESDIR}"/eliloalt.8-${PV} eliloalt.8
+}
diff --git a/sys-boot/elilo/files/digest-elilo-3.4-r2 b/sys-boot/elilo/files/digest-elilo-3.4-r2
new file mode 100644
index 000000000000..6c9603e2135d
--- /dev/null
+++ b/sys-boot/elilo/files/digest-elilo-3.4-r2
@@ -0,0 +1 @@
+MD5 e7357929dfca29436d35ad6386fc051c elilo-3.4.tar.gz 316518
diff --git a/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch b/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch
new file mode 100644
index 000000000000..5796b0f05d13
--- /dev/null
+++ b/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch
@@ -0,0 +1,15 @@
+Fix an error with newer binutils:
+
+setjmp.S: Assembler messages:
+setjmp.S:170: Error: .endp outside of procedure
+
+--- elilo-3.4/ia64/setjmp.S
++++ elilo-3.4/ia64/setjmp.S
+@@ -78,6 +78,7 @@
+
+ /* __sigsetjmp(__jmp_buf buf, int savemask) */
+
++ .proc __sigsetjmp
+ __sigsetjmp:
+ //.prologue ASM_UNW_PRLG_RP|ASM_UNW_PRLG_PFS, ASM_UNW_PRLG_GRSAVE(2)
+ alloc loc1=ar.pfs,2,2,2,0