summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-06-22 00:02:26 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-06-22 00:02:26 +0000
commit859303b9d1023e1c78590998f51d4b2fa36c5633 (patch)
treed1d641fc198a181aa591dbf906b223eaf17f06f8 /sys-cluster/ganglia-web
parentepatch: make sure we sort dirs of patches consistently #471666 by Pavel Riha (diff)
downloadgentoo-2-859303b9d1023e1c78590998f51d4b2fa36c5633.tar.gz
gentoo-2-859303b9d1023e1c78590998f51d4b2fa36c5633.tar.bz2
gentoo-2-859303b9d1023e1c78590998f51d4b2fa36c5633.zip
bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/ganglia-web')
-rw-r--r--sys-cluster/ganglia-web/ChangeLog7
-rw-r--r--sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild4
-rw-r--r--sys-cluster/ganglia-web/ganglia-web-3.5.8.ebuild57
3 files changed, 65 insertions, 3 deletions
diff --git a/sys-cluster/ganglia-web/ChangeLog b/sys-cluster/ganglia-web/ChangeLog
index 67b1e5199c61..7143e70ebb18 100644
--- a/sys-cluster/ganglia-web/ChangeLog
+++ b/sys-cluster/ganglia-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ganglia-web
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ChangeLog,v 1.9 2013/02/24 17:37:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ChangeLog,v 1.10 2013/06/22 00:02:26 jsbronder Exp $
+
+*ganglia-web-3.5.8 (21 Jun 2013)
+
+ 21 Jun 2013; Justin Bronder <jsbronder@gentoo.org> +ganglia-web-3.5.8.ebuild:
+ bump
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ganglia-web-3.5.6.ebuild:
Stable for x86, wrt bug #456812
diff --git a/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild b/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild
index b4846466b6c5..333b89688d19 100644
--- a/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild
+++ b/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild
@@ -1,6 +1,6 @@
-#Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild,v 1.4 2013/02/24 17:37:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ganglia-web-3.5.6.ebuild,v 1.5 2013/06/22 00:02:26 jsbronder Exp $
EAPI=4
WEBAPP_MANUAL_SLOT="yes"
diff --git a/sys-cluster/ganglia-web/ganglia-web-3.5.8.ebuild b/sys-cluster/ganglia-web/ganglia-web-3.5.8.ebuild
new file mode 100644
index 000000000000..70ed2bbb2bca
--- /dev/null
+++ b/sys-cluster/ganglia-web/ganglia-web-3.5.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ganglia-web-3.5.8.ebuild,v 1.1 2013/06/22 00:02:26 jsbronder Exp $
+
+EAPI=4
+WEBAPP_MANUAL_SLOT="yes"
+inherit webapp eutils
+
+DESCRIPTION="Web frontend for sys-cluster/ganglia"
+HOMEPAGE="http://ganglia.sourceforge.net"
+SRC_URI="mirror://sourceforge/ganglia/${PN}/${PV}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vhosts"
+
+DEPEND="net-misc/rsync"
+RDEPEND="
+ ${DEPEND}
+ ${WEBAPP_DEPEND}
+ >=sys-cluster/ganglia-3.3.7[-minimal]
+ dev-lang/php[gd,xml,ctype,cgi]
+ media-fonts/dejavu"
+
+src_configure() {
+ return 0
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ webapp_src_preinst
+ cd "${S}"
+ emake \
+ GDESTDIR="${MY_HTDOCSDIR}" \
+ DESTDIR="${D}" \
+ APACHE_USER=nobody \
+ install || die
+ webapp_configfile "${MY_HTDOCSDIR}"/conf_default.php
+ webapp_src_install
+
+ fowners -R nobody:nobody /var/lib/ganglia-web/dwoo
+ fperms -R 777 /var/lib/ganglia-web/dwoo
+
+ dodoc AUTHORS README TODO || die
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ # upgrade from < 3.5.6
+ if [ -d "${ROOT}"/var/lib/ganglia/dwoo ]; then
+ rm -rf "${ROOT}"/var/lib/ganglia/dwoo || die
+ fi
+}