summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-23 01:46:04 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-23 01:46:04 +0000
commit9a40a346ad05c5bca776c1868a7e84f32bda4537 (patch)
tree7f20a9d9f404f725f8f6e397d1758f295a7ac140 /sys-devel/crossdev
parentold (diff)
downloadgentoo-2-9a40a346ad05c5bca776c1868a7e84f32bda4537.tar.gz
gentoo-2-9a40a346ad05c5bca776c1868a7e84f32bda4537.tar.bz2
gentoo-2-9a40a346ad05c5bca776c1868a7e84f32bda4537.zip
Build with --with-headers by default as gcc-4.3 relies on them a lot more #227065.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9.18-r9.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev4
3 files changed, 31 insertions, 3 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index c05bbd6e7e55..d91058ffabd0 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.58 2008/05/16 17:43:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.59 2008/06/23 01:46:04 vapier Exp $
+
+*crossdev-0.9.18-r9 (23 Jun 2008)
+
+ 23 Jun 2008; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.18-r9.ebuild:
+ Build with --with-headers by default as gcc-4.3 relies on them a lot more
+ #227065.
*crossdev-0.9.18-r8 (16 May 2008)
diff --git a/sys-devel/crossdev/crossdev-0.9.18-r9.ebuild b/sys-devel/crossdev/crossdev-0.9.18-r9.ebuild
new file mode 100644
index 000000000000..0fec32deff8c
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.18-r9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.18-r9.ebuild,v 1.1 2008/06/23 01:46:04 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ || ( dev-util/unifdef sys-freebsd/freebsd-ubin )"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index d56d5efcdd86..0726fcba3c00 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.103 2008/05/16 17:43:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.104 2008/06/23 01:46:04 vapier Exp $
cd /
umask 0022 #159111
@@ -331,7 +331,7 @@ LCAT="sys-libs" ; LPKG="" ; LVER="" ; LUSE=""
DEFAULT_VER="[latest]"
GUSE_DISABLE="-boundschecking -d -fortran -gtk -gcj -libffi -mudflap -objc -objc++ -objc-gc -openmp"
GUSE_DISABLE_STAGE_2=${GUSE_DISABLE/-fortran}
-WITH_HEADERS="COW" WITH_DEF_HEADERS="no"
+WITH_HEADERS="COW" WITH_DEF_HEADERS="yes" #227065 gcc-4.3+ is a pita w/out headers
EX_FAST="no"
EX_GCC="no"
EX_GDB="no"