summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-04 00:10:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-04 00:10:39 +0000
commit7c6551a526928e39fc41e0f473025eb6e3bb5c15 (patch)
tree2ecacf3886fca0af1e0b626b9b550134dd3a9f6f /sys-devel
parentamd64/arm/ia64/ppc stable (diff)
downloadgentoo-2-7c6551a526928e39fc41e0f473025eb6e3bb5c15.tar.gz
gentoo-2-7c6551a526928e39fc41e0f473025eb6e3bb5c15.tar.bz2
gentoo-2-7c6551a526928e39fc41e0f473025eb6e3bb5c15.zip
use /usr/lib/misc instead of /usr/libexec
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-devel')
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.108
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild7
2 files changed, 8 insertions, 7 deletions
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.10 b/sys-devel/gcc-config/files/gcc-config-1.3.10
index 911e33c4acfe..009f08d0d324 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.10
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.10
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.10,v 1.2 2005/02/01 05:38:27 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.10,v 1.3 2005/02/04 00:10:39 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
trap ":" INT QUIT TSTP
@@ -206,7 +206,7 @@ switch_profile() {
local ref=${ROOT}/${GCC_BIN_PATH}/${x}
[[ ${x} = "cc" ]] && ref=${ROOT}/${GCC_BIN_PATH}/gcc
if [[ -x ${ref} ]] ; then
- ${CP} -f "${ROOT}/usr/libexec/gcc-config/wrapper" \
+ ${CP} -f "${ROOT}/usr/lib/misc/gcc-config" \
"${ROOT}/usr/bin/${x}"
touch -r "${ref}" "${ROOT}/usr/bin/${x}"
@@ -214,7 +214,7 @@ switch_profile() {
# This should probably get folded back into the wrapper ...
if [[ ${x:${#x}-3} = "gcc" ]] || [[ ${x:${#x}-3} = "g++" ]] ; then
for bits in ${GCCBITS} ; do
- cp -f "${ROOT}/usr/libexec/gcc-config/wrapper" \
+ cp -f "${ROOT}/usr/lib/misc/gcc-config" \
"${ROOT}/usr/bin/${x}${bits}"
done
fi
@@ -223,7 +223,7 @@ switch_profile() {
# Only install cpp if switching to a native one
if ! is_cross_compiler ; then
${RM} -f "${ROOT}/lib/cpp"
- ${CP} -f "${ROOT}/usr/libexec/gcc-config/wrapper" "${ROOT}/lib/cpp"
+ ${CP} -f "${ROOT}/usr/lib/misc/gcc-config" "${ROOT}/lib/cpp"
fi
# We need to make sure that libgcc_s.so makes it into /lib.
diff --git a/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild b/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild
index 09452108c9e3..7ac2b6a7e1b0 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild,v 1.2 2005/02/01 18:18:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.10-r1.ebuild,v 1.3 2005/02/04 00:10:39 vapier Exp $
inherit toolchain-funcs
@@ -14,6 +14,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
DEPEND="virtual/libc
>=sys-apps/portage-2.0.47-r10" # We need portageq ...
@@ -29,8 +30,8 @@ src_install() {
newbin ${FILESDIR}/${PN}-${PV} ${PN} || die "install gcc-config"
dosed "s:PORTAGE-VERSION:${PVR}:" /usr/bin/${PN}
- exeinto /usr/libexec/gcc-config
- doexe wrapper || die "install wrapper"
+ exeinto /usr/lib/misc
+ newexe wrapper gcc-config || die "install wrapper"
}
pkg_postinst() {