summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-08-30 10:37:20 +0000
committerPeter Volkov <pva@gentoo.org>2010-08-30 10:37:20 +0000
commitf2d75435ea13806f5801a75d92da490a3bcb4f8c (patch)
treea9f5a69515263fb0a5ef1ddbf181c00424e4ce21 /sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild
parentFix running tests with USE=-tcl. Fixes bug #335179. (diff)
downloadgentoo-2-f2d75435ea13806f5801a75d92da490a3bcb4f8c.tar.gz
gentoo-2-f2d75435ea13806f5801a75d92da490a3bcb4f8c.tar.bz2
gentoo-2-f2d75435ea13806f5801a75d92da490a3bcb4f8c.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild')
-rw-r--r--sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild b/sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild
new file mode 100644
index 000000000000..a57c769303dd
--- /dev/null
+++ b/sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/openvz-sources-2.6.32.7.1.ebuild,v 1.1 2010/08/30 10:37:20 pva Exp $
+
+inherit versionator
+
+# Upstream uses string to version their releases. To make portage version
+# comparisment working we have to use numbers instead of strings, that is 4th
+# component of our version. So we have aivazovsky - 1, briullov - 2 and so on.
+# Keep this string on top since we have to modify it each new release.
+OVZ_CODENAME="bykovsky"
+OVZ_CODENAME_SUBRELEASE=$(get_version_component_range 5)
+
+OVZ_KV="${OVZ_CODENAME}.${OVZ_CODENAME_SUBRELEASE}"
+
+ETYPE="sources"
+
+CKV=$(get_version_component_range 1-3)
+OKV=${OKV:-${CKV}}
+EXTRAVERSION=-${PN/-*}-${OVZ_KV}
+KV_FULL=${CKV}${EXTRAVERSION}
+if [[ ${PR} != r0 ]]; then
+ KV_FULL+=-${PR}
+ EXTRAVERSION+=-${PR}
+fi
+
+# ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} should succeed.
+KV_MAJOR=$(get_version_component_range 1 ${OKV})
+KV_MINOR=$(get_version_component_range 2 ${OKV})
+KV_PATCH=$(get_version_component_range 3 ${OKV})
+
+KERNEL_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.bz2"
+
+inherit kernel-2
+detect_version
+
+SLOT=${CKV}-${OVZ_KV}
+if [[ ${PR} != r0 ]]; then
+ SLOT+=-${PR}
+fi
+
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DESCRIPTION="Kernel sources with OpenVZ patchset"
+HOMEPAGE="http://www.openvz.org"
+SRC_URI="${KERNEL_URI} ${ARCH_URI}
+ http://download.openvz.org/kernel/branches/${CKV}/${CKV}-${OVZ_KV}/patches/patch-${OVZ_KV}-combined.gz"
+
+UNIPATCH_STRICTORDER=1
+UNIPATCH_LIST="${DISTDIR}/patch-${OVZ_KV}-combined.gz"
+
+K_EXTRAEINFO="For more information about this kernel take a look at:
+http://wiki.openvz.org/Download/kernel/${CKV}/${CKV}-${OVZ_KV}"