summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-17 06:11:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-17 06:11:29 +0000
commit729813ab447050752c89f5346ed3a8450ed12faf (patch)
tree3279fc9ccad316b94841cf0e2007580ea9ddaf73 /sys-process/glances
parentBump (diff)
downloadgentoo-2-729813ab447050752c89f5346ed3a8450ed12faf.tar.gz
gentoo-2-729813ab447050752c89f5346ed3a8450ed12faf.tar.bz2
gentoo-2-729813ab447050752c89f5346ed3a8450ed12faf.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-process/glances')
-rw-r--r--sys-process/glances/ChangeLog7
-rw-r--r--sys-process/glances/glances-1.7.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-process/glances/ChangeLog b/sys-process/glances/ChangeLog
index 8644394e199b..b25961c8fdbf 100644
--- a/sys-process/glances/ChangeLog
+++ b/sys-process/glances/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/glances
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.12 2013/11/16 09:33:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.13 2013/12/17 06:11:29 patrick Exp $
+
+*glances-1.7.3 (17 Dec 2013)
+
+ 17 Dec 2013; Patrick Lauer <patrick@gentoo.org> +glances-1.7.3.ebuild:
+ Bump
*glances-1.7.2 (16 Nov 2013)
diff --git a/sys-process/glances/glances-1.7.3.ebuild b/sys-process/glances/glances-1.7.3.ebuild
new file mode 100644
index 000000000000..dde67d322908
--- /dev/null
+++ b/sys-process/glances/glances-1.7.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-1.7.3.ebuild,v 1.1 2013/12/17 06:11:29 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+MYPN=Glances
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/psutil[${PYTHON_USEDEP}]"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:share/doc/glances:share/doc/${PF}:g" \
+ -e "s/'COPYING',//" \
+ -e "s:/etc:${EPREFIX}/etc:" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "${PN} can gain additional functionality with following packages:"
+ elog " dev-python/jinja - export statistics to HTML"
+ elog " app-admin/hddtemp - monitor hard drive temperatures"
+ fi
+}