summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-02-11 18:48:31 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-02-11 18:48:31 +0000
commit9cc3030673345c517f0afd0d3998a9576400ce9c (patch)
tree9a15da1deb27760be84850a4fd9898aee74fd5d2 /www-apache
parentDev channel bump. (diff)
downloadgentoo-2-9cc3030673345c517f0afd0d3998a9576400ce9c.tar.gz
gentoo-2-9cc3030673345c517f0afd0d3998a9576400ce9c.tar.bz2
gentoo-2-9cc3030673345c517f0afd0d3998a9576400ce9c.zip
Version bump.
(Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/ChangeLog10
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.25.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index f4febaf979a8..842d0430aa24 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_caucho
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.61 2011/09/06 16:42:52 nelchael Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.62 2012/02/11 18:48:31 nelchael Exp $
+
+*mod_caucho-4.0.25 (11 Feb 2012)
+
+ 11 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org>
+ +mod_caucho-4.0.25.ebuild:
+ Version bump.
*mod_caucho-4.0.22 (06 Sep 2011)
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild
new file mode 100644
index 000000000000..c8ac2f8d6880
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.25.ebuild,v 1.1 2012/02/11 18:48:31 nelchael Exp $
+
+EAPI="2"
+
+inherit eutils apache-module autotools
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
+
+need_apache2
+
+src_prepare() {
+ for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
+ epatch "${i}"
+ done
+
+ mkdir m4
+ eautoreconf
+ chmod 755 ./configure
+}
+
+src_configure() {
+ econf --with-apxs=${APXS} || die "econf failed"
+}
+
+src_compile() {
+ emake -C "${S}/modules/c/src/apache2/" || die "emake failed"
+}