summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-01-05 19:28:42 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-01-05 19:28:42 +0000
commitf6bf808231641e68761cb765d6575e596a3ca56b (patch)
tree5e6ce2d9d93e7a689e5599469677c9ff52e1ee4e /www-client
parentmirror from gentopia, cause it has more fixes! (diff)
downloadgentoo-2-f6bf808231641e68761cb765d6575e596a3ca56b.tar.gz
gentoo-2-f6bf808231641e68761cb765d6575e596a3ca56b.tar.bz2
gentoo-2-f6bf808231641e68761cb765d6575e596a3ca56b.zip
Make sure that python is build with readline support -- closes #204272.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/pybugz/ChangeLog5
-rw-r--r--www-client/pybugz/pybugz-0.7.3.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/www-client/pybugz/ChangeLog b/www-client/pybugz/ChangeLog
index f9229c905775..0434ee32140d 100644
--- a/www-client/pybugz/ChangeLog
+++ b/www-client/pybugz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/pybugz
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/ChangeLog,v 1.26 2008/01/04 12:51:45 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/ChangeLog,v 1.27 2008/01/05 19:28:42 williamh Exp $
+
+ 05 Jan 2008; William Hubbs <williamh@gentoo.org> pybugz-0.7.3.ebuild:
+ Make sure that python is built with readline support -- closes #204272.
04 Jan 2008; Markus Ullmann <jokey@gentoo.org> pybugz-0.7.3.ebuild:
arm keyword for bug 203717
diff --git a/www-client/pybugz/pybugz-0.7.3.ebuild b/www-client/pybugz/pybugz-0.7.3.ebuild
index 20f13dec4331..3093e5c9025b 100644
--- a/www-client/pybugz/pybugz-0.7.3.ebuild
+++ b/www-client/pybugz/pybugz-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/pybugz-0.7.3.ebuild,v 1.2 2008/01/04 12:51:45 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/pybugz-0.7.3.ebuild,v 1.3 2008/01/05 19:28:42 williamh Exp $
inherit distutils
@@ -14,3 +14,12 @@ IUSE=""
DEPEND="|| ( >=dev-lang/python-2.5
( >=dev-lang/python-2.4
dev-python/elementtree ) )"
+
+ pkg_setup() {
+ if ! built_with_use dev-lang/python readline; then
+ eerror
+ eerror "Python is not built with readline support."
+ eerror "Please re-emerge python with readline in your use flags."
+ die "python must be built with readline support."
+ fi
+ }