summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-10-03 23:30:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-10-03 23:30:34 +0000
commit189714da803c920a951a0ae580312afeae5541a0 (patch)
treec2fed54abdb76d2fdfa899073c56dd1898c95f3d /www-plugins
parentarm stable, bug #379423 (diff)
downloadgentoo-2-189714da803c920a951a0ae580312afeae5541a0.tar.gz
gentoo-2-189714da803c920a951a0ae580312afeae5541a0.tar.bz2
gentoo-2-189714da803c920a951a0ae580312afeae5541a0.zip
Version bump, based on submission in bug #358779.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/mozplugger/ChangeLog8
-rw-r--r--www-plugins/mozplugger/files/mozplugger-1.14.3-Makefile.in.patch30
-rw-r--r--www-plugins/mozplugger/metadata.xml3
-rw-r--r--www-plugins/mozplugger/mozplugger-1.14.3.ebuild50
4 files changed, 90 insertions, 1 deletions
diff --git a/www-plugins/mozplugger/ChangeLog b/www-plugins/mozplugger/ChangeLog
index fd5ee48ef32f..b6711b6475d5 100644
--- a/www-plugins/mozplugger/ChangeLog
+++ b/www-plugins/mozplugger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/mozplugger
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozplugger/ChangeLog,v 1.10 2011/01/15 10:37:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozplugger/ChangeLog,v 1.11 2011/10/03 23:30:34 robbat2 Exp $
+
+*mozplugger-1.14.3 (03 Oct 2011)
+
+ 03 Oct 2011; Robin H. Johnson <robbat2@gentoo.org> +mozplugger-1.14.3.ebuild,
+ +files/mozplugger-1.14.3-Makefile.in.patch, metadata.xml:
+ Version bump, based on submission in bug #358779.
15 Jan 2011; Michał Górny <mgorny@gentoo.org> mozplugger-1.14.2.ebuild:
Drop the xulrunner dependency as mozplugger bundles the necessary NPAPI
diff --git a/www-plugins/mozplugger/files/mozplugger-1.14.3-Makefile.in.patch b/www-plugins/mozplugger/files/mozplugger-1.14.3-Makefile.in.patch
new file mode 100644
index 000000000000..0b46f8be2039
--- /dev/null
+++ b/www-plugins/mozplugger/files/mozplugger-1.14.3-Makefile.in.patch
@@ -0,0 +1,30 @@
+--- a/Makefile.in 2011-03-03 14:40:49.000000000 -0700
++++ b/Makefile.in 2011-05-09 11:34:55.000000000 -0600
+@@ -152,17 +152,16 @@
+ make localinstall BROWSERDIR=.opera
+
+ install:
+- -@$(MKDIR) @bindir@
+- -@$(MKDIR) $(prefix)$(libprefix)/mozilla/plugins
+- -@$(MKDIR) @mandir@/man7
+- -@$(MKDIR) @sysconfdir@
+- cp mozplugger-helper @bindir@
+- cp mozplugger-controller @bindir@
+- cp mozplugger-linker @bindir@
+- for target in ${PLUGINDIRS}; do cp mozplugger.so $${target}; done
+-# cp mozplugger.so $(prefix)$(libprefix)/mozilla/plugins/
+- cp $(srcdir)/mozpluggerrc @sysconfdir@
+- cp $(srcdir)/mozplugger.7 @mandir@/man7/
++ -@$(MKDIR) ${root}@bindir@
++ -@$(MKDIR) $(root)$(prefix)$(libprefix)/nsbrowser/plugins
++ -@$(MKDIR) ${root}@mandir@/man7
++ -@$(MKDIR) ${root}@sysconfdir@
++ cp mozplugger-helper ${root}@bindir@
++ cp mozplugger-controller ${root}@bindir@
++ cp mozplugger-linker ${root}@bindir@
++ cp mozplugger.so ${root}$(prefix)$(libprefix)/nsbrowser/plugins/
++ cp $(srcdir)/mozpluggerrc ${root}@sysconfdir@
++ cp $(srcdir)/mozplugger.7 ${root}@mandir@/man7/
+
+ mozplugger.tar.gz: $(SOURCE_FILES)
+ @( DIR=`pwd`;\
diff --git a/www-plugins/mozplugger/metadata.xml b/www-plugins/mozplugger/metadata.xml
index 2ca888880170..3c33369b5880 100644
--- a/www-plugins/mozplugger/metadata.xml
+++ b/www-plugins/mozplugger/metadata.xml
@@ -6,4 +6,7 @@
<email>chutzpah@gentoo.org</email>
<name>Patrick McLean</name>
</maintainer>
+<use>
+ <flag name="xembed">Build with xembed always enabled.</flag>
+</use>
</pkgmetadata>
diff --git a/www-plugins/mozplugger/mozplugger-1.14.3.ebuild b/www-plugins/mozplugger/mozplugger-1.14.3.ebuild
new file mode 100644
index 000000000000..88643296cf91
--- /dev/null
+++ b/www-plugins/mozplugger/mozplugger-1.14.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozplugger/mozplugger-1.14.3.ebuild,v 1.1 2011/10/03 23:30:34 robbat2 Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Configurable browser plugin to launch streaming media players."
+SRC_URI="http://mozplugger.mozdev.org/files/${P}.tar.gz"
+HOMEPAGE="http://mozplugger.mozdev.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="xembed"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.14.3-Makefile.in.patch"
+ sed -i "s:libprefix=.*:libprefix=/$(get_libdir):" Makefile.in
+}
+
+src_configure() {
+ local myconf
+ if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
+ if use xembed; then
+ myconf="${myconf} --enable-always-xembed"
+ fi
+
+ econf \
+ ${myconf}
+ fi
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ XCFLAGS="-fPIC -Wall" \
+ COMMON_LDFLAGS="${LDFLAGS}" \
+ all || die
+}
+
+src_install() {
+ emake root="${D}" install || die
+ dodoc ChangeLog README
+}