summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-28 10:13:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-28 10:13:25 +0000
commita038e7247a965277d35362ceeb8158fd6daeecc8 (patch)
treed5560cf85acf58442004235dbd3d6f60044a6509 /x11-drivers/xf86-input-wacom
parenttidy (diff)
downloadgentoo-2-a038e7247a965277d35362ceeb8158fd6daeecc8.tar.gz
gentoo-2-a038e7247a965277d35362ceeb8158fd6daeecc8.tar.bz2
gentoo-2-a038e7247a965277d35362ceeb8158fd6daeecc8.zip
Version bump to latest.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.0.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index dafdb097f3da..695cd1a68ea1 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.39 2011/04/18 11:30:03 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.40 2011/04/28 10:13:25 scarabeus Exp $
+
+*xf86-input-wacom-0.11.0 (28 Apr 2011)
+
+ 28 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +xf86-input-wacom-0.11.0.ebuild:
+ Version bump to latest.
18 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-xf86-input-wacom-0.10.8-r1.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.0.ebuild
new file mode 100644
index 000000000000..d7ea6eabfe24
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.0.ebuild,v 1.1 2011/04/28 10:13:25 scarabeus Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="!x11-drivers/linuxwacom
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}