summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-06-10 12:56:57 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-06-10 12:56:57 +0000
commited342b1da060b50dee092f37f356108b63e350fd (patch)
tree85b5d07f4349ec168728af7af037dbd1ebb19198 /x11-libs/qt
parentStable on sparc wrt #92995 (diff)
downloadgentoo-2-ed342b1da060b50dee092f37f356108b63e350fd.tar.gz
gentoo-2-ed342b1da060b50dee092f37f356108b63e350fd.tar.bz2
gentoo-2-ed342b1da060b50dee092f37f356108b63e350fd.zip
Release candidate
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog7
-rw-r--r--x11-libs/qt/Manifest2
-rw-r--r--x11-libs/qt/files/digest-qt-4.0.0_rc11
-rw-r--r--x11-libs/qt/qt-4.0.0_rc1.ebuild185
4 files changed, 194 insertions, 1 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index edcf3e7a512a..240f14841821 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.224 2005/06/03 21:03:13 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.225 2005/06/10 12:56:57 caleb Exp $
+
+*qt-4.0.0_rc1 (10 Jun 2005)
+
+ 10 Jun 2005; Caleb Tennis <caleb@gentoo.org> +qt-4.0.0_rc1.ebuild:
+ Release candidate
*qt-4.0.0_beta2-r3 (03 Jun 2005)
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index a1c67f97ab29..2ee6f3035fa3 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -7,6 +7,7 @@ MD5 98c2c897d6bb5fd3f7c6af49cd8decb7 qt-3.3.4-r2.ebuild 8565
MD5 e5e1f28d1973386abc7d593bd7330d62 qt-3.3.4-r4.ebuild 9306
MD5 ba90334609abff61295bcf8e5f374eca ChangeLog 37358
MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
+MD5 dccef7c3062af4616d9208f8ea2b1df8 qt-4.0.0_rc1.ebuild 6059
MD5 74acd4c098f2c4bd70bdea585f0cb096 files/qt-no-rpath.patch 352
MD5 8ffca1b1b7523339af04fd24b4595ce4 files/0001-dnd_optimization.patch 5623
MD5 0cc401186f490faf55906cd458280db8 files/0037-dnd-timestamp-fix.patch 2138
@@ -23,6 +24,7 @@ MD5 c115b4205c2a2eab0a547375e2f62460 files/digest-qt-3.3.4-r4 166
MD5 0221c85bc6f785b68812fc7f42110742 files/qt-3.3.3-flickerfree_qscrollview_fixwindowactivate.patch 1540
MD5 2df2442dc59faeb8b545a81d2523cf28 files/qt-3.3.3-immodule-r123-event-inversion-20040909.diff 327
MD5 8c01ee8bb9af451f93082717ed8f4c49 files/qfontdatabase_x11.diff 1147
+MD5 bed89221628547eb8f12da37622493e0 files/digest-qt-4.0.0_rc1 90
MD5 7dc4f78d52452c28ba797ffc7db34f23 files/50qtdir3 16
MD5 991b96a8a42dd07997732db50d11bd5a files/qt4b2_nomkdir.patch 755
MD5 b9689fa9461944ba25ebf0acde5fb70b files/qt-3.3.3-flickerfree_qiconview_buffered.patch 3347
diff --git a/x11-libs/qt/files/digest-qt-4.0.0_rc1 b/x11-libs/qt/files/digest-qt-4.0.0_rc1
new file mode 100644
index 000000000000..f48da9c018ee
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-4.0.0_rc1
@@ -0,0 +1 @@
+MD5 f7f48c9f7de7fd93a414e45ef691ebea qt-x11-opensource-desktop-4.0.0-rc1.tar.bz2 15465019
diff --git a/x11-libs/qt/qt-4.0.0_rc1.ebuild b/x11-libs/qt/qt-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..394c77c6414d
--- /dev/null
+++ b/x11-libs/qt/qt-4.0.0_rc1.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_rc1.ebuild,v 1.1 2005/06/10 12:56:57 caleb Exp $
+
+inherit eutils flag-o-matic
+
+SRCTYPE="opensource-desktop"
+#SNAPSHOT="20050603"
+SNAPSHOT=""
+DESCRIPTION="QT version ${PV}"
+HOMEPAGE="http://www.trolltech.com/"
+
+#SRC_URI="ftp://ftp.trolltech.com/qt/snapshots/qt-x11-${SRCTYPE}-${PV}-snapshot-${SNAPSHOT}.tar.bz2"
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV/_rc1/-rc1}.tar.bz2"
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV/_rc1/-rc1}
+
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="4"
+KEYWORDS="-*"
+IUSE="accessibility cups debug doc examples firebird gif ipv6 jpeg mng mysql nas nis odbc opengl postgres png sqlite xinerama zlib"
+
+DEPEND="virtual/x11 virtual/xft >=media-libs/freetype-2
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mng? ( media-libs/libmng )
+ nas? ( >=media-libs/nas-1.5 )
+ odbc? ( dev-db/unixODBC )
+ mysql? ( dev-db/mysql )
+ firebird? ( dev-db/firebird )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( dev-db/postgresql )
+ cups? ( net-print/cups )
+ zlib? ( sys-libs/zlib )"
+
+pkg_setup() {
+ QTBASEDIR=/usr/$(get_libdir)/qt4
+ QTPREFIXDIR=${S}
+ QTBINDIR=/usr/bin
+ QTLIBDIR=/usr/$(get_libdir)/qt4
+ QTDOCDIR=/usr/share/qt4/doc
+ QTDATADIR=/usr/share/qt4
+ QTHEADERDIR=/usr/include/qt4
+ QTPLUGINDIR=/usr/$(get_libdir)/qt4/plugins
+ QTSYSCONFDIR=/etc/qt4
+ QTTRANSDIR=/usr/share/qt4/translations
+
+ PLATFORM=$(qt_mkspecs_dir)
+}
+
+qt_use() {
+ useq ${1} && echo "-${1}" || echo "-no-${1}"
+ return 0
+}
+
+qt_mkspecs_dir() {
+ # Allows us to define which mkspecs dir we want to use. Currently we only use
+ # linux-g++ or linux-g++-64, but others could be used for various platforms.
+
+ if [[ $(get_libdir) == "lib" ]]; then
+ echo "linux-g++"
+ else
+ echo "linux-g++-64"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+
+ cd mkspecs/$(qt_mkspecs_dir)
+ # set c/xxflags and ldflags
+ strip-flags
+
+ # Qt4 moc does not work with -O3, unfortunately.
+ replace-flags -O3 -O2
+ filter-flags -finline-functions
+
+ sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
+ -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
+ -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
+ qmake.conf
+ cd ${S}
+
+ epatch ${FILESDIR}/qt4-rpath.patch
+ epatch ${FILESDIR}/qt4b2r3_nomkdir.patch
+
+ sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
+}
+
+src_compile() {
+ export SYSCONF=${D}${QTPREFIXDIR}/etc/settings
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ # Fixes for 89704
+ export LC_ALL=C
+ export LANG=C
+
+ # Let's just allow writing to these directories during Qt emerge
+ # as it makes Qt much happier.
+ # addwrite "${QTBASE}/etc/settings"
+ # addwrite "$HOME/.qt"
+
+ myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
+ myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
+ use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
+ use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
+ use debug && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
+ use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
+
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
+ use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
+ use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
+ use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
+
+ myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
+
+ ./configure -stl -verbose -largefile \
+ -platform ${PLATFORM} -xplatform ${PLATFORM} \
+ -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
+ -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
+ -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} ${myconf} || die
+
+ emake sub-tools-all-ordered || die
+}
+
+src_install() {
+ export SYSCONF=${D}${QTPREFIXDIR}/etc/settings
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ # make INSTALL_ROOT=${D} sub-demos-install_subtargets-ordered sub-examples-install_subtargets-ordered || die
+ # make INSTALL_ROOT=${D} install_qmake sub-tools-install_subtargets-ordered || die
+ # Using install_qmake forces lots of other things to build. Bypass it for now.
+
+ make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
+ if use examples; then
+ dodir ${QTDATADIR}/examples
+ cp -a ${S}/examples/* ${D}/${QTDATADIR}/examples
+ dodir ${QTDATADIR}/demos
+ cp -a ${S}/demos/* ${D}/${QTDATADIR}/demos
+ fi
+
+ #install -c ${S}/bin/qmake ${D}${QTBINDIR}/qmake
+ make INSTALL_ROOT=${D} install_qmake || die
+ make INSTALL_ROOT=${D} install_mkspecs || die
+
+ # Fix symlink
+ cd ${D}/${QTDATADIR}/mkspecs
+ rm default
+ ln -s $(qt_mkspecs_dir) default
+ cd ${S}
+
+ if use doc; then
+ make INSTALL_ROOT=${D} install_htmldocs || die
+ fi
+
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
+ sed -i -e "s:${S}:${QTBASEDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
+
+ # Don't need to install stray linguist files
+ rm -rf ${D}/${DATADIR}/phrasebooks/linguist
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:/usr/${libdir}/qt4"
+ done
+ cat > ${D}/etc/env.d/44qt4 << EOF
+PATH=${QTBINDIR}
+ROOTPATH=${QTBINDIR}
+LDPATH=${libdirs:1}
+QMAKESPEC=$(qt_mkspecs_dir)
+EOF
+}