summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-05-11 09:29:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-05-11 09:29:05 +0000
commit57efd5417d7a8ef720b94e7040e57be9e262d3a0 (patch)
tree70d52e9d5edea205ceb0ba48304165acb74e355a /x11-libs/vdpau-video
parentinitial import, bug #308871, ebuild by Olivier Huber <oli.huber@gmail.com> wi... (diff)
downloadgentoo-2-57efd5417d7a8ef720b94e7040e57be9e262d3a0.tar.gz
gentoo-2-57efd5417d7a8ef720b94e7040e57be9e262d3a0.tar.bz2
gentoo-2-57efd5417d7a8ef720b94e7040e57be9e262d3a0.zip
initial import, bug #317317, ebuild by Frank Richter <res@crystalspace3d.org> with small modifications by me
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vdpau-video')
-rw-r--r--x11-libs/vdpau-video/ChangeLog11
-rw-r--r--x11-libs/vdpau-video/metadata.xml9
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.6.9.ebuild38
3 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/vdpau-video/ChangeLog b/x11-libs/vdpau-video/ChangeLog
new file mode 100644
index 000000000000..a6bd18086f86
--- /dev/null
+++ b/x11-libs/vdpau-video/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-libs/vdpau-video
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.1 2010/05/11 09:29:05 aballier Exp $
+
+*vdpau-video-0.6.9 (11 May 2010)
+
+ 11 May 2010; Alexis Ballier <aballier@gentoo.org>
+ +vdpau-video-0.6.9.ebuild, +metadata.xml:
+ initial import, bug #317317, ebuild by Frank Richter
+ <res@crystalspace3d.org> with small modifications by me
+
diff --git a/x11-libs/vdpau-video/metadata.xml b/x11-libs/vdpau-video/metadata.xml
new file mode 100644
index 000000000000..5c913a45f55c
--- /dev/null
+++ b/x11-libs/vdpau-video/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-libs/vdpau-video/vdpau-video-0.6.9.ebuild b/x11-libs/vdpau-video/vdpau-video-0.6.9.ebuild
new file mode 100644
index 000000000000..6b5e0d0c06dc
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.6.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.6.9.ebuild,v 1.1 2010/05/11 09:29:05 aballier Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.splitted-desktop.com/~gbeauchesne/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}