summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-01-09 21:36:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-01-09 21:36:18 +0000
commit2bd197558e6e63990f2636ad5b11562ca8b79a50 (patch)
tree2f2e5aa5c474e7f9dc138692f01f32e970dd8052 /x11-libs/vte
parentbump to 2.20.3 (diff)
downloadgentoo-2-2bd197558e6e63990f2636ad5b11562ca8b79a50.tar.gz
gentoo-2-2bd197558e6e63990f2636ad5b11562ca8b79a50.tar.bz2
gentoo-2-2bd197558e6e63990f2636ad5b11562ca8b79a50.zip
bump to 0.16.12
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog9
-rw-r--r--x11-libs/vte/files/digest-vte-0.16.123
-rw-r--r--x11-libs/vte/vte-0.16.12.ebuild68
3 files changed, 78 insertions, 2 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 064c7bdf9ab9..f2cb2d4d2e40 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.188 2007/12/22 15:55:37 eva Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.189 2008/01/09 21:36:17 eva Exp $
+
+*vte-0.16.12 (09 Jan 2008)
+
+ 09 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.16.12.ebuild:
+ bump to 0.16.12
*vte-0.16.11 (22 Dec 2007)
diff --git a/x11-libs/vte/files/digest-vte-0.16.12 b/x11-libs/vte/files/digest-vte-0.16.12
new file mode 100644
index 000000000000..f42443bcda4b
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.16.12
@@ -0,0 +1,3 @@
+MD5 9816c35be2ff1b0cf57bd831e1344d1d vte-0.16.12.tar.bz2 1113860
+RMD160 124308bb69475fef114c36daac51a6d1639a2564 vte-0.16.12.tar.bz2 1113860
+SHA256 7f0865c5cf5a433052bc6e67ce90f479df6322e37ebbc6f4462f8d947f18978f vte-0.16.12.tar.bz2 1113860
diff --git a/x11-libs/vte/vte-0.16.12.ebuild b/x11-libs/vte/vte-0.16.12.ebuild
new file mode 100644
index 000000000000..06e50c684ae1
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.12.ebuild,v 1.1 2008/01/09 21:36:17 eva Exp $
+
+inherit eutils gnome2 autotools python
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug) $(use_enable python)
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch"
+ cd "${S}/gnome-pty-helper"
+
+ # eautoreconf will break on systems without gtk-doc
+ eautomake
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+ fi
+}