summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-10-28 07:56:49 +0000
committerNaohiro Aota <naota@gentoo.org>2011-10-28 07:56:49 +0000
commitc88ee727f08e6d3a570aaeec671110a35ab6fe7e (patch)
tree560efd4e4160d2b4ca783d143f45f6027dce9de6 /x11-terms/mlterm
parentppc stable wrt #314939 (diff)
downloadgentoo-2-c88ee727f08e6d3a570aaeec671110a35ab6fe7e.tar.gz
gentoo-2-c88ee727f08e6d3a570aaeec671110a35ab6fe7e.tar.bz2
gentoo-2-c88ee727f08e6d3a570aaeec671110a35ab6fe7e.zip
Version bump.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/mlterm')
-rw-r--r--x11-terms/mlterm/ChangeLog8
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.7-ldflags.patch277
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.7-underlinking.patch13
-rw-r--r--x11-terms/mlterm/mlterm-3.0.7.ebuild93
4 files changed, 390 insertions, 1 deletions
diff --git a/x11-terms/mlterm/ChangeLog b/x11-terms/mlterm/ChangeLog
index a9a540231872..8efe7e7bb9ae 100644
--- a/x11-terms/mlterm/ChangeLog
+++ b/x11-terms/mlterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/mlterm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.79 2011/08/18 02:19:26 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.80 2011/10/28 07:56:49 naota Exp $
+
+*mlterm-3.0.7 (28 Oct 2011)
+
+ 28 Oct 2011; Naohiro Aota <naota@gentoo.org> +mlterm-3.0.7.ebuild,
+ +files/mlterm-3.0.7-ldflags.patch, +files/mlterm-3.0.7-underlinking.patch:
+ Version bump.
*mlterm-3.0.6 (18 Aug 2011)
diff --git a/x11-terms/mlterm/files/mlterm-3.0.7-ldflags.patch b/x11-terms/mlterm/files/mlterm-3.0.7-ldflags.patch
new file mode 100644
index 000000000000..90de20026fbd
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.7-ldflags.patch
@@ -0,0 +1,277 @@
+diff -Naur mlterm-3.0.5.orig/contrib/scrollbar/extra/Makefile.in mlterm-3.0.5/contrib/scrollbar/extra/Makefile.in
+--- mlterm-3.0.5.orig/contrib/scrollbar/extra/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/scrollbar/extra/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -20,7 +20,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/contrib/scrollbar/pixmap_engine/Makefile.in mlterm-3.0.5/contrib/scrollbar/pixmap_engine/Makefile.in
+--- mlterm-3.0.5.orig/contrib/scrollbar/pixmap_engine/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/scrollbar/pixmap_engine/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -20,7 +20,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in mlterm-3.0.5/contrib/tool/mlcc/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlcc/Makefile.in 2011-06-09 23:29:02.851741057 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJECTS)
+- $(CC) -g -o $(PROG) $(OBJECTS)
++ $(CC) -g -o $(PROG) $(OBJECTS) $(LDFLAGS)
+
+ .SUFFIXES: .c.o
+
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlterm-menu/Makefile.in mlterm-3.0.5/contrib/tool/mlterm-menu/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlterm-menu/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlterm-menu/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -30,7 +30,7 @@
+
+ LIBS = $(LIBS1) $(LIBS2@WIN32TAG@)
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlterm-zoom/Makefile.in mlterm-3.0.5/contrib/tool/mlterm-zoom/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlterm-zoom/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlterm-zoom/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -21,7 +21,7 @@
+ LIBS = $(LIBS_LOCAL) @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+ #LIBS = $(LIBS_LOCAL) @X_LIBS@ @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/gtk/Makefile.in mlterm-3.0.5/gtk/Makefile.in
+--- mlterm-3.0.5.orig/gtk/Makefile.in 2011-06-04 01:26:09.000000000 +0900
++++ mlterm-3.0.5/gtk/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -18,7 +18,7 @@
+ -DSYSCONFDIR=\"$(SYSCONFDIR)\" @VTE_CFLAGS@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ OBJ = vte.o marshal.o vtetypebuiltins.o reaper.o
+diff -Naur mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in mlterm-3.0.5/inputmethod/ibus/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/ibus/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/iiimf/Makefile.in mlterm-3.0.5/inputmethod/iiimf/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/iiimf/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/iiimf/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/kbd/Makefile.in mlterm-3.0.5/inputmethod/kbd/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/kbd/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/kbd/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -28,7 +28,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/m17nlib/Makefile.in mlterm-3.0.5/inputmethod/m17nlib/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/m17nlib/Makefile.in 2011-06-04 01:26:37.000000000 +0900
++++ mlterm-3.0.5/inputmethod/m17nlib/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/scim/Makefile.in mlterm-3.0.5/inputmethod/scim/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/scim/Makefile.in 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/scim/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -33,7 +33,7 @@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+ LIBTOOL_CXX = $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c .cpp
+diff -Naur mlterm-3.0.5.orig/inputmethod/uim/Makefile.in mlterm-3.0.5/inputmethod/uim/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/uim/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/uim/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/kiklib/src/Makefile.in mlterm-3.0.5/kiklib/src/Makefile.in
+--- mlterm-3.0.5.orig/kiklib/src/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/kiklib/src/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -30,7 +30,7 @@
+ INC = $(COMOBJ:.o=.h) kik_list.h kik_iterator.h kik_types.h kik_util.h kik_def.h kik_net.h kik_pty.h kik_utmp.h kik_dlfcn.h
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LIBS)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LIBS) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ LIBNAME=libkik
+diff -Naur mlterm-3.0.5.orig/mkf/lib/Makefile.in mlterm-3.0.5/mkf/lib/Makefile.in
+--- mlterm-3.0.5.orig/mkf/lib/Makefile.in 2011-06-04 01:26:16.000000000 +0900
++++ mlterm-3.0.5/mkf/lib/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -52,7 +52,7 @@
+ MINOR = 0
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+
+diff -Naur mlterm-3.0.5.orig/mkf/libtbl/Makefile.in mlterm-3.0.5/mkf/libtbl/Makefile.in
+--- mlterm-3.0.5.orig/mkf/libtbl/Makefile.in 2011-06-04 01:26:15.000000000 +0900
++++ mlterm-3.0.5/mkf/libtbl/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -24,7 +24,7 @@
+ OBJ = $(JAJP_TABLE_OBJ) $(KOKR_TABLE_OBJ) $(ZH_TABLE_OBJ) $(BYTE_TABLE_OBJ)
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: libmkf_jajp.la libmkf_kokr.la libmkf_zh.la libmkf_8bits.la
+diff -Naur mlterm-3.0.5.orig/mlterm/Makefile.in mlterm-3.0.5/mlterm/Makefile.in
+--- mlterm-3.0.5.orig/mlterm/Makefile.in 2011-06-04 01:26:09.000000000 +0900
++++ mlterm-3.0.5/mlterm/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -33,7 +33,7 @@
+ MINOR = 0
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+
+diff -Naur mlterm-3.0.5.orig/scrollbar/sample/Makefile.in mlterm-3.0.5/scrollbar/sample/Makefile.in
+--- mlterm-3.0.5.orig/scrollbar/sample/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/scrollbar/sample/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -33,7 +33,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/tool/mlclient/Makefile.in mlterm-3.0.5/tool/mlclient/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlclient/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlclient/Makefile.in 2011-06-09 23:27:57.251467757 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJ)
+- $(CC) -o $(PROG) $(OBJ) $(LIBS)
++ $(CC) -o $(PROG) $(OBJ) $(LIBS) $(LDFLAGS)
+ cp $(PROG) $(PROG)x
+
+ .SUFFIXES: .c.o
+diff -Naur mlterm-3.0.5.orig/tool/mlconfig/Makefile.in mlterm-3.0.5/tool/mlconfig/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlconfig/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlconfig/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -42,7 +42,7 @@
+
+ LIBS = $(LIBS1) $(LIBS2@WIN32TAG@)
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/tool/mlimgloader/Makefile.in mlterm-3.0.5/tool/mlimgloader/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlimgloader/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlimgloader/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -32,7 +32,7 @@
+ INSTALL_OPT = @INSTALL_OPT@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: $(PROG)
+diff -Naur mlterm-3.0.5.orig/tool/mlmenu/Makefile.in mlterm-3.0.5/tool/mlmenu/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlmenu/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlmenu/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -18,7 +18,7 @@
+ LIBS = $(LIBS_LOCAL) @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+ #LIBS = $(LIBS_LOCAL) @X_LIBS@ @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/xwindow/Makefile.in mlterm-3.0.5/xwindow/Makefile.in
+--- mlterm-3.0.5.orig/xwindow/Makefile.in 2011-06-04 01:26:10.000000000 +0900
++++ mlterm-3.0.5/xwindow/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -64,7 +64,7 @@
+ INSTALL_OPT = @INSTALL_OPT@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: $(PROG)
+diff --git a/xwindow/libtype/Makefile.in b/xwindow/libtype/Makefile.in
+index 391c1fa..fff76f6 100644
+--- a/xwindow/libtype/Makefile.in
++++ b/xwindow/libtype/Makefile.in
+@@ -37,7 +37,7 @@ LIBS = $(LIBS_LOCAL) $(LMKF) $(LKIK) -L/usr/local/lib -R/usr/local/lib
+ INSTALL_OPT = -m 755
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ TYPE_LIBS = @TYPE_LIBS@
diff --git a/x11-terms/mlterm/files/mlterm-3.0.7-underlinking.patch b/x11-terms/mlterm/files/mlterm-3.0.7-underlinking.patch
new file mode 100644
index 000000000000..4e5ed669037e
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.7-underlinking.patch
@@ -0,0 +1,13 @@
+diff --git a/xwindow/Makefile.in b/xwindow/Makefile.in
+index 50137e0..1e83104 100644
+--- a/xwindow/Makefile.in
++++ b/xwindow/Makefile.in
+@@ -32,7 +32,7 @@ OBJ = $(OBJ1) $(OBJ2@WIN32TAG@)
+
+ LKIK = @LKIK@
+ LMKF = @LMKF@
+-LMLTERM = ../mlterm/libmlterm.a ../mlterm/@LMLTERM_CORE@
++LMLTERM = ../mlterm/libmlterm.a ../mlterm/@LMLTERM_CORE@ -lm
+ LKIK_DEB = -lkik_deb
+ LMKF_DEB = -lmkf_deb
+
diff --git a/x11-terms/mlterm/mlterm-3.0.7.ebuild b/x11-terms/mlterm/mlterm-3.0.7.ebuild
new file mode 100644
index 000000000000..b3500433ad5d
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.0.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-3.0.7.ebuild,v 1.1 2011/10/28 07:56:49 naota Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+IUSE="bidi debug gtk ibus libssh2 m17n-lib nls scim static-libs uim xft"
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlterm/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="|| ( sys-libs/libutempter sys-apps/utempter )
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ gtk? ( x11-libs/gtk+:2 )
+ xft? ( x11-libs/libXft )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ ibus? ( >=app-i18n/ibus-1.3 )
+ libssh2? ( net-libs/libssh2 )
+ nls? ( virtual/libintl )
+ uim? ( >=app-i18n/uim-1.0 )
+ scim? ( >=app-i18n/scim-1.4 )
+ m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )"
+# vte? ( x11-libs/vte )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.9.4-uim15-fix.patch \
+ "${FILESDIR}"/${PN}-3.0.5-ibus.patch \
+ "${FILESDIR}"/${PN}-3.0.7-ldflags.patch \
+ "${FILESDIR}"/${PN}-3.0.7-underlinking.patch
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ if use gtk ; then
+ myconf="${myconf} --with-imagelib=gdk-pixbuf"
+ else
+ myconf="${myconf} --with-tools=mlclient,mlcc"
+ fi
+
+ if use xft ; then
+ myconf="${myconf} --with-type-engines=xft"
+ else
+ myconf="${myconf} --with-type-engines=xcore"
+ fi
+
+ # iiimf isn't stable enough
+ #myconf="${myconf} $(use_enable iiimf)"
+
+ econf --enable-utmp \
+ $(use_enable bidi fribidi) \
+ $(use_enable debug) \
+ $(use_enable ibus) \
+ $(use_enable libssh2 ssh2) \
+ $(use_enable nls) \
+ $(use_enable uim) \
+ $(use_enable scim) \
+ $(use_enable m17n-lib m17nlib) \
+ $(use_enable static-libs static) \
+ ${myconf} || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ doicon contrib/icon/mlterm* || die
+ make_desktop_entry mlterm mlterm mlterm-icon TerminalEmulator || die
+
+ dodoc ChangeLog README || die
+
+ docinto ja
+ dodoc doc/ja/* || die
+ docinto en
+ dodoc doc/en/* || die
+}