summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-11-06 16:11:32 +0000
committerJeroen Roovers <jer@gentoo.org>2013-11-06 16:11:32 +0000
commitdfb57647175c29cf80ba46e2f8355899cb65ec60 (patch)
tree31a40a08b0dbbfc835f9c737c59dc23cd0f9f91c /x11-terms/rxvt-unicode
parentAdd ruby20. Remove ree18. (diff)
downloadgentoo-2-dfb57647175c29cf80ba46e2f8355899cb65ec60.tar.gz
gentoo-2-dfb57647175c29cf80ba46e2f8355899cb65ec60.tar.bz2
gentoo-2-dfb57647175c29cf80ba46e2f8355899cb65ec60.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch12
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild135
3 files changed, 154 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 29ebd129b8d3..cbed1a842245 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.248 2013/06/09 23:07:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.249 2013/11/06 16:11:32 jer Exp $
+
+*rxvt-unicode-9.19 (06 Nov 2013)
+
+ 06 Nov 2013; Jeroen Roovers <jer@gentoo.org> +rxvt-unicode-9.19.ebuild,
+ +files/rxvt-unicode-9.19-fading.patch:
+ Version bump.
09 Jun 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml:
Add upstream CPE tag (security info) from ChromiumOS.
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch
new file mode 100644
index 000000000000..50bb27e8123f
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch
@@ -0,0 +1,12 @@
+--- a/src/rxvtperl.xs
++++ b/src/rxvtperl.xs
+@@ -818,7 +818,9 @@
+ // TODO: should support all colour constants, create colorinc.h &c
+ const_iv (Color_fg),
+ const_iv (Color_bg),
++#ifdef OFF_FOCUS_FADING
+ const_iv (Color_fade),
++#endif
+ const_iv (Color_pointer_fg),
+ const_iv (Color_pointer_bg),
+ const_iv (Color_border),
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild
new file mode 100644
index 000000000000..3b25bef304a6
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild,v 1.1 2013/11/06 16:11:32 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="
+ 256-color alt-font-width blink buffer-on-clear +focused-urgency
+ fading-colors +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
+ startup-notification xft unicode3 +vanilla wcwidth
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r6
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ media-libs/fontconfig
+ perl? ( dev-lang/perl )
+ pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ startup-notification? ( x11-libs/startup-notification )
+ x11-libs/libX11
+ x11-libs/libXrender
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+
+RESTRICT="test"
+REQUIRED_USE="vanilla? ( !alt-font-width !buffer-on-clear focused-urgency !secondary-wheel !wcwidth )"
+
+src_prepare() {
+ # fix for prefix not installing properly
+ epatch \
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch \
+ "${FILESDIR}"/${PN}-9.15-xsubpp.patch \
+ "${FILESDIR}"/${PN}-9.19-fading.patch
+
+ if ! use vanilla; then
+ ewarn "You are going to include unsupported third-party bug fixes/features."
+ ewarn "If you want even more control over patches, then set USE=vanilla"
+ ewarn "and store your patch set in /etc/portage/patches/${CATEGORY}/${PF}/"
+
+ use wcwidth && epatch doc/wcwidth.patch
+
+ # bug #240165
+ use focused-urgency || epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
+
+ # bug #263638
+ epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
+
+ # bug #237271
+ epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
+
+ # support for wheel scrolling on secondary screens
+ use secondary-wheel && epatch "${FILESDIR}"/${PN}-9.14-secondary-wheel.patch
+
+ # ctrl-l buffer fix
+ use buffer-on-clear && epatch "${FILESDIR}"/${PN}-9.14-clear.patch
+
+ use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
+ else
+ epatch_user
+ fi
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf --enable-everything \
+ $(use_enable 256-color) \
+ $(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable mousewheel) \
+ $(use_enable perl) \
+ $(use_enable pixbuf) \
+ $(use_enable startup-notification) \
+ $(use_enable xft) \
+ $(use_enable unicode3) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ default
+
+ dodoc \
+ README.FAQ Changes doc/README* doc/changes.txt doc/etc/* doc/rxvt-tabbed
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}
+
+pkg_postinst() {
+ if use buffer-on-clear; then
+ ewarn "You have enabled the buffer-on-clear USE flag."
+ ewarn "Please note that, although this works well for most prompts,"
+ ewarn "there have been cases with fancy prompts, like bug #397829,"
+ ewarn "where it caused issues. Proceed with caution."
+ ewarn " (keep this terminal open until you make sure it works)"
+ fi
+ if use secondary-wheel; then
+ elog "You have enabled the secondary-wheel USE flag."
+ elog "This allows you to scroll in secondary screens"
+ elog "(like mutt's message list/view) using the mouse wheel."
+ elog
+ elog "To actually enable the feature you have to add"
+ elog " URxvt*secondaryWheel: true"
+ elog "in your ~/.Xdefaults file"
+ fi
+}