summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-09 18:42:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-09 18:42:49 +0000
commit7255f3e4168ddb48fb7bb93c17686101e11f7c18 (patch)
tree172da6c353ac8c51689d73a5da41cd441e84af16 /xfce-extra/xfce4-weather-plugin
parentFix bug 389949 (by scribeofthenile) where compilation failed in unrealircd-3.... (diff)
downloadgentoo-2-7255f3e4168ddb48fb7bb93c17686101e11f7c18.tar.gz
gentoo-2-7255f3e4168ddb48fb7bb93c17686101e11f7c18.tar.bz2
gentoo-2-7255f3e4168ddb48fb7bb93c17686101e11f7c18.zip
Change PARTNER_ID and LICENSE_KEY wrt upstream http://bugzilla.xfce.org/show_bug.cgi?id=8105
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/ChangeLog b/xfce-extra/xfce4-weather-plugin/ChangeLog
index fac1109023a0..c4b1467d96d4 100644
--- a/xfce-extra/xfce4-weather-plugin/ChangeLog
+++ b/xfce-extra/xfce4-weather-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-weather-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.13 2011/02/03 22:30:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.14 2011/11/09 18:42:49 ssuominen Exp $
+
+*xfce4-weather-plugin-0.7.4-r1 (09 Nov 2011)
+
+ 09 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-weather-plugin-0.7.4-r1.ebuild:
+ Change PARTNER_ID and LICENSE_KEY wrt upstream
+ http://bugzilla.xfce.org/show_bug.cgi?id=8105
*xfce4-weather-plugin-0.7.4 (03 Feb 2011)
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..c090d65ab05e
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild,v 1.1 2011/11/09 18:42:49 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8
+ >=dev-libs/libxml2-2.4"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ # http://bugzilla.xfce.org/show_bug.cgi?id=8105#c9
+ sed -i \
+ -e '/PARTNER_ID/s:1121946239:1003666583:' \
+ -e '/LICENSE_KEY/s:3c4cd39ee5dec84f:4128909340a9b2fc:' \
+ panel-plugin/weather.h || die
+
+ xfconf_src_prepare
+}