summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/commons-graph/ChangeLog6
-rw-r--r--dev-java/commons-graph/Manifest12
-rw-r--r--dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild7
3 files changed, 10 insertions, 15 deletions
diff --git a/dev-java/commons-graph/ChangeLog b/dev-java/commons-graph/ChangeLog
index 458bd452134c..ce2b9e1b9903 100644
--- a/dev-java/commons-graph/ChangeLog
+++ b/dev-java/commons-graph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-graph
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/ChangeLog,v 1.3 2005/12/04 22:47:12 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/ChangeLog,v 1.4 2005/12/04 23:17:04 nichoj Exp $
+
+ 04 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ commons-graph-0.8.1_p20040118.ebuild:
+ Fixed to not install a versioned jar.
04 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
commons-graph-0.8.1_p20040118.ebuild:
diff --git a/dev-java/commons-graph/Manifest b/dev-java/commons-graph/Manifest
index cf2dabdb8b58..76b83829945c 100644
--- a/dev-java/commons-graph/Manifest
+++ b/dev-java/commons-graph/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 bc2504b914177aa57d43ec7f593eba23 ChangeLog 710
-MD5 d0f2cfc96f83cc6b74144e063ef799a3 commons-graph-0.8.1_p20040118.ebuild 1759
+MD5 4891b795e5c3d20ec7322e7146943d3f commons-graph-0.8.1_p20040118.ebuild 1817
MD5 361f23cd46c14f40fbb6590b564f20a5 files/commons-graph-0.8.1_p20040118-gentoo.diff 758
MD5 bf85b87a012c334e20d661447bbf52b4 files/digest-commons-graph-0.8.1_p20040118 75
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDk3IFndWRXhKOboURAtZCAJ9//TLhpffFbwT7o8ipWwfczn8VngCeIIWH
-CiPYPFm3AifgqGf24lK+2Nc=
-=xwt1
------END PGP SIGNATURE-----
diff --git a/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild b/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
index 4d199580a765..b38b3a636b43 100644
--- a/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
+++ b/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild,v 1.3 2005/12/04 22:47:12 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild,v 1.4 2005/12/04 23:17:04 nichoj Exp $
inherit java-pkg eutils
MY_PN=graph2
MY_PV=${PV%%_*}.cvs${PV##*_p}
MY_P=${MY_PN}-${MY_PV}
+API_PV=${PV%%_*}
DESCRIPTION="A toolkit for managing graphs and graph based data structures"
-# There doesn't seem to be a real home page
+# There doesn't seem to be a real home page, so we'll point to a viewcvs
HOMEPAGE="http://cvs.apache.org/viewcvs/jakarta-commons-sandbox/graph2/"
# this was extracted from a source rpm at jpackage
SRC_URI="mirror://gentoo/distfiles/${MY_P}.tar.gz"
@@ -48,7 +49,7 @@ src_compile(){
}
src_install(){
- java-pkg_dojar target/commons-graph*.jar
+ java-pkg_newjar target/${PN}-${API_PV}.jar ${PN}.jar
use doc && java-pkg_dohtml -r dist/docs/api
}