summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/nsscache/ChangeLog7
-rw-r--r--net-nds/nsscache/files/nsscache-0.8.3-starttls.patch33
-rw-r--r--net-nds/nsscache/nsscache-0.8.3-r1.ebuild3
3 files changed, 29 insertions, 14 deletions
diff --git a/net-nds/nsscache/ChangeLog b/net-nds/nsscache/ChangeLog
index 59ecdfd65f2a..198e10c0fb26 100644
--- a/net-nds/nsscache/ChangeLog
+++ b/net-nds/nsscache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/nsscache
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.4 2009/05/24 21:00:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.5 2009/05/24 23:53:36 robbat2 Exp $
+
+ 24 May 2009; Robin H. Johnson <robbat2@gentoo.org>
+ nsscache-0.8.3-r1.ebuild, files/nsscache-0.8.3-starttls.patch:
+ Respin patch to apply better without the ../ and also make sure the state
+ directory is created by default.
*nsscache-0.8.3-r1 (24 May 2009)
diff --git a/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch b/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch
index c345c958f137..2ca9c1feec9b 100644
--- a/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch
+++ b/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch
@@ -3,35 +3,44 @@ Add a new configuration file to do it.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-diff -Nuar ../nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py ../nsscache-0.8.3/nss_cache/sources/ldapsource.py
---- ../nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py 2008-09-08 18:31:58.000000000 -0700
-+++ ../nsscache-0.8.3/nss_cache/sources/ldapsource.py 2009-05-24 13:56:14.009240803 -0700
+diff -Nuar nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py nsscache-0.8.3/nss_cache/sources/ldapsource.py
+--- nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py 2008-09-08 18:31:58.000000000 -0700
++++ nsscache-0.8.3/nss_cache/sources/ldapsource.py 2009-05-24 16:50:59.579112740 -0700
@@ -76,6 +76,8 @@
self.conn = rlo(uri=conf['uri'],
retry_max=conf['retry_max'],
retry_delay=conf['retry_delay'])
-+ if configuration['ldap_tls_starttls'] == 1:
++ if conf['tls_starttls'] == 1:
+ self.conn.start_tls_s()
else:
self.conn = conn
-@@ -120,6 +122,13 @@
+@@ -107,6 +109,8 @@
+ configuration['tls_cacertdir'] = self.TLS_CACERTDIR
+ if not 'tls_cacertfile' in configuration:
+ configuration['tls_cacertfile'] = self.TLS_CACERTFILE
++ if not 'tls_starttls' in configuration:
++ configuration['tls_starttls'] = 0
+
+ # Translate tls_require into appropriate constant, if necessary.
+ if configuration['tls_require_cert'] == 'never':
+@@ -120,6 +124,13 @@
elif configuration['tls_require_cert'] == 'try':
configuration['tls_require_cert'] = ldap.OPT_X_TLS_TRY
+ # Should we issue STARTTLS?
-+ if configuration['ldap_tls_starttls'] in (1, '1', 'on', 'yes', 'true'):
-+ configuration['ldap_tls_starttls'] = 1
-+ #if not configuration['ldap_tls_starttls']:
++ if configuration['tls_starttls'] in (1, '1', 'on', 'yes', 'true'):
++ configuration['tls_starttls'] = 1
++ #if not configuration['tls_starttls']:
+ else:
-+ configuration['ldap_tls_starttls'] = 0
++ configuration['tls_starttls'] = 0
+
# Setting global ldap defaults.
ldap.set_option(ldap.OPT_X_TLS_REQUIRE_CERT,
configuration['tls_require_cert'])
-diff -Nuar ../nsscache-0.8.3.orig/nsscache.conf ../nsscache-0.8.3/nsscache.conf
---- ../nsscache-0.8.3.orig/nsscache.conf 2008-09-08 18:31:58.000000000 -0700
-+++ ../nsscache-0.8.3/nsscache.conf 2009-05-24 13:56:18.182858446 -0700
+diff -Nuar nsscache-0.8.3.orig/nsscache.conf nsscache-0.8.3/nsscache.conf
+--- nsscache-0.8.3.orig/nsscache.conf 2008-09-08 18:31:58.000000000 -0700
++++ nsscache-0.8.3/nsscache.conf 2009-05-24 16:51:25.468374563 -0700
@@ -70,6 +70,9 @@
# Default filename for trusted CAs
#ldap_tls_cacertfile = '/usr/share/ssl/cert.pem'
diff --git a/net-nds/nsscache/nsscache-0.8.3-r1.ebuild b/net-nds/nsscache/nsscache-0.8.3-r1.ebuild
index c97e9bcb62f8..7d4d10349806 100644
--- a/net-nds/nsscache/nsscache-0.8.3-r1.ebuild
+++ b/net-nds/nsscache/nsscache-0.8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/nsscache-0.8.3-r1.ebuild,v 1.1 2009/05/24 21:00:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/nsscache-0.8.3-r1.ebuild,v 1.2 2009/05/24 23:53:36 robbat2 Exp $
inherit distutils
@@ -29,4 +29,5 @@ src_install() {
doins "$FILESDIR/nsscache.conf" # overwrite default with working config.
doman *.[1-8]
dodoc THANKS nsscache.cron
+ keepdir /var/lib/nsscache
}