summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-mta/exim/ChangeLog10
-rw-r--r--mail-mta/exim/exim-4.69-r1.ebuild4
-rw-r--r--mail-mta/exim/files/exim-4.69-r1.27021.patch57
-rw-r--r--mail-mta/exim/files/exim-4.69-r1.boolean_redefine_protect.152706.patch21
4 files changed, 90 insertions, 2 deletions
diff --git a/mail-mta/exim/ChangeLog b/mail-mta/exim/ChangeLog
index 1c3bd1202c58..89c97f40ffb3 100644
--- a/mail-mta/exim/ChangeLog
+++ b/mail-mta/exim/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for mail-mta/exim
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.128 2008/05/21 16:04:10 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.129 2008/07/12 17:42:23 peitolm Exp $
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> exim-4.69.ebuild,
exim-4.69-r1.ebuild:
@@ -13,6 +13,14 @@
14 May 2008; Diego Pettenò <flameeyes@gentoo.org> exim-4.69-r1.ebuild:
Depend on virtual/pam as the code builds fine with OpenPAM.
+ 05 May 2008; Colin Morey <peitolm@gentoo.org>
+ +files/exim-4.69-r1.27021.patch,
+ +files/exim-4.69-r1.boolean_redefine_protect.152706.patch,
+ exim-4.69-r1.ebuild:
+ Patches added from:-
+ #27021 - mail-mta/exim - Mail filtering and maildir enhancements for exim.conf
+ #152706 - mail-mta/exim - use shared libpcre + other fixed
+
24 Apr 2008; Raúl Porcel <armin76@gentoo.org> -files/digest-exim-4.68,
-files/digest-exim-4.69, -files/digest-exim-4.69-r1:
Remove digests
diff --git a/mail-mta/exim/exim-4.69-r1.ebuild b/mail-mta/exim/exim-4.69-r1.ebuild
index 8d69ae984a3e..d8d152be2027 100644
--- a/mail-mta/exim/exim-4.69-r1.ebuild
+++ b/mail-mta/exim/exim-4.69-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.69-r1.ebuild,v 1.4 2008/05/21 16:04:10 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.69-r1.ebuild,v 1.5 2008/07/12 17:42:23 peitolm Exp $
inherit eutils
@@ -56,6 +56,8 @@ src_unpack() {
epatch "${FILESDIR}"/exim-4.14-tail.patch
epatch "${FILESDIR}"/exim-4.43-r2-localscan_dlopen.patch
+ epatch "${FILESDIR}"/exim-4.69-r1.27021.patch
+ epatch "${FILESDIR}"/exim-4.69-r1.boolean_redefine_protect.152706.patch
if use maildir; then
einfo "Patching maildir support into exim.conf"
diff --git a/mail-mta/exim/files/exim-4.69-r1.27021.patch b/mail-mta/exim/files/exim-4.69-r1.27021.patch
new file mode 100644
index 000000000000..72b048632a6a
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.69-r1.27021.patch
@@ -0,0 +1,57 @@
+diff -urN exim-4.69.orig/src/configure.default exim-4.69/src/configure.default
+--- exim-4.69.orig/src/configure.default 2008-05-05 10:17:44.000000000 +0100
++++ exim-4.69/src/configure.default 2008-05-05 10:18:26.000000000 +0100
+@@ -592,6 +592,22 @@
+ pipe_transport = address_pipe
+ reply_transport = address_reply
+
++# This router runs procmail if users have a .procmailrc file
++procmail:
++ check_local_user
++ driver = accept
++ transport = procmail_pipe
++ require_files = ${local_part}:+${home}:+${home}/.procmailrc:+/usr/bin/procmail
++ no_verify
++
++# This router runs maildrop if users have a .mailfilter file
++maildrop:
++ check_local_user
++ driver = accept
++ transport = maildrop_pipe
++ require_files = ${local_part}:+${home}:+${home}/.mailfilter:+/usr/bin/maildrop
++ no_verify
++
+
+ # This router matches local user mailboxes. If the router fails, the error
+ # message is "Unknown user".
+@@ -600,7 +616,7 @@
+ # or "+" characters as if the suffixes did not exist, uncomment the two local_
+ # part_suffix options. Then, for example, xxxx-foo@your.domain will be treated
+ # in the same way as xxxx@your.domain by this router.
+-
++m
+ localuser:
+ driver = accept
+ check_local_user
+@@ -676,6 +692,21 @@
+ address_reply:
+ driver = autoreply
+
++# This transport is used for procmail
++procmail_pipe:
++ driver = pipe
++ command = "/usr/bin/procmail -d ${local_part}"
++ return_path_add
++ delivery_date_add
++ envelope_to_add
++
++# This transport is used for courier-maildrop filtering (Maildir filter system)
++maildrop_pipe:
++ driver = pipe
++ command = "/usr/bin/maildrop -d ${local_part}"
++ return_path_add
++ delivery_date_add
++ envelope_to_add
+
+
+ ######################################################################
diff --git a/mail-mta/exim/files/exim-4.69-r1.boolean_redefine_protect.152706.patch b/mail-mta/exim/files/exim-4.69-r1.boolean_redefine_protect.152706.patch
new file mode 100644
index 000000000000..eba3cb18d01b
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.69-r1.boolean_redefine_protect.152706.patch
@@ -0,0 +1,21 @@
+diff -urN exim-4.69.orig/src/mytypes.h exim-4.69/src/mytypes.h
+--- exim-4.69.orig/src/mytypes.h 2007-01-08 10:50:18.000000000 +0000
++++ exim-4.69/src/mytypes.h 2008-05-05 10:48:09.000000000 +0100
+@@ -16,9 +16,17 @@
+ #define MYTYPES_H
+
+
++#ifndef FALSE
+ #define FALSE 0
++#endif
++
++#ifndef TRUE
+ #define TRUE 1
++#endif
++
++#ifndef TRUE_UNSET
+ #define TRUE_UNSET 2
++#endif
+
+
+ /* If gcc is being used to compile Exim, we can use its facility for checking