summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/auctex/ChangeLog6
-rw-r--r--app-emacs/auctex/auctex-11.84-r2.ebuild98
-rw-r--r--app-emacs/auctex/files/50auctex-gentoo.el8
3 files changed, 5 insertions, 107 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index 5c2e32c97d65..84f2ef4ac093 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/auctex
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.80 2008/01/23 11:37:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.81 2008/02/11 07:55:14 opfer Exp $
+
+ 11 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/50auctex-gentoo.el, -auctex-11.84-r2.ebuild:
+ clean up
23 Jan 2008; Raúl Porcel <armin76@gentoo.org> auctex-11.84-r3.ebuild:
sparc stable wrt #206992
diff --git a/app-emacs/auctex/auctex-11.84-r2.ebuild b/app-emacs/auctex/auctex-11.84-r2.ebuild
deleted file mode 100644
index 58581e991789..000000000000
--- a/app-emacs/auctex/auctex-11.84-r2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.84-r2.ebuild,v 1.8 2007/12/22 17:23:00 dertobi123 Exp $
-
-inherit elisp eutils latex-package
-
-DESCRIPTION="An extensible package that supports writing and formatting TeX files"
-HOMEPAGE="http://www.gnu.org/software/auctex/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 FDL-1.2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="preview-latex"
-
-DEPEND="virtual/tetex
- preview-latex? ( !dev-tex/preview-latex
- app-text/dvipng
- virtual/ghostscript )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # skip XEmacs detection. this is a workaround for emacs23
- epatch "${FILESDIR}/${P}-configure.diff"
- # allow compilation of Japanese TeX files, fixed in upstream's CVS
- # not needed for next release (>=11.85)
- epatch "${FILESDIR}/${P}-japanes.patch"
-}
-
-src_compile() {
- # Don't install in the main tree, as this causes file collisions
- # with app-text/tetex, see bug #155944
- if use preview-latex; then
- local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
- local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
-
- if [ -z "${TEXMFPATH}" ]; then
- eerror "You haven't defined the TEXMFSITE variable in your TeX config."
- eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
- die "Define TEXMFSITE in TeX configuration!"
- else
- # go through the colon separated list of directories (maybe only one) provided in the variable
- # TEXMFPATH (generated from TEXMFSITE from TeX's config) and choose only the first entry.
- # All entries are separated by colons, even when defined with semi-colons, kpsewhich changes
- # the output to a generic format, so IFS has to be redefined.
- local IFS="${IFS}:"
-
- for strippedpath in ${TEXMFPATH}
- do
- if [ -d ${strippedpath} ]; then
- local PREVIEW_TEXMFDIR="${strippedpath}"
- break
- fi
- done
-
- # verify if an existing path was chosen to prevent from installing into the wrong directory
- if [ -z ${PREVIEW_TEXMFDIR} ]; then
- eerror "TEXMFSITE does not contain any existing directory."
- eerror "Please define an existing directory in your TeX config file"
- eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
- die "TEXMFSITE variable did not contain an existing directory"
- fi
-
- dodir "${PREVIEW_TEXMFDIR}"
- fi
- fi
-
- econf --disable-build-dir-test \
- --with-auto-dir="${D}/var/lib/auctex" \
- --with-lispdir="${D}/${SITELISP}" \
- --with-texmf-dir="${D}/${PREVIEW_TEXMFDIR}" \
- $(use_enable preview-latex preview) || die "econf failed"
- emake || die "emake failed"
- cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
-}
-
-src_install() {
- einstall || die "einstall failed"
- dosed "${SITELISP}/tex-site.el" || die "dosed failed"
- elisp-site-file-install "${FILESDIR}/52auctex-gentoo.el"
- if use preview-latex; then
- elisp-site-file-install "${FILESDIR}/60auctex-gentoo.el"
- fi
- dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL* doc/tex-ref.pdf
-}
-
-pkg_postinst() {
- # rebuild TeX-inputfiles-database
- use preview-latex && latex-package_pkg_postinst
- elisp-site-regen
-}
-
-pkg_postrm(){
- use preview-latex && latex-package_pkg_postrm
- elisp-site-regen
-}
diff --git a/app-emacs/auctex/files/50auctex-gentoo.el b/app-emacs/auctex/files/50auctex-gentoo.el
deleted file mode 100644
index ad4377967194..000000000000
--- a/app-emacs/auctex/files/50auctex-gentoo.el
+++ /dev/null
@@ -1,8 +0,0 @@
-
-;;; auctex site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-(require 'tex-site)
-
-;; detect needed steps after rebuild
-(setq TeX-parse-self t)