summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/sharutils/sharutils-4.11.ebuild')
-rw-r--r--app-arch/sharutils/sharutils-4.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/sharutils/sharutils-4.11.ebuild b/app-arch/sharutils/sharutils-4.11.ebuild
new file mode 100644
index 000000000000..993b2cec8d6c
--- /dev/null
+++ b/app-arch/sharutils/sharutils-4.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.11.ebuild,v 1.1 2011/02/06 16:55:15 jer Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Tools to deal with shar archives"
+HOMEPAGE="http://www.gnu.org/software/sharutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ strip-linguas -u po
+ econf $(use_enable nls)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}