summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tinyca/tinyca-2.0.7.2.ebuild')
-rw-r--r--app-crypt/tinyca/tinyca-2.0.7.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/tinyca/tinyca-2.0.7.2.ebuild b/app-crypt/tinyca/tinyca-2.0.7.2.ebuild
new file mode 100644
index 000000000000..997c1fafe451
--- /dev/null
+++ b/app-crypt/tinyca/tinyca-2.0.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tinyca/tinyca-2.0.7.2.ebuild,v 1.1 2006/05/28 12:02:59 dragonheart Exp $
+
+inherit eutils
+
+MY_P="${PN}${PV/./-}"
+DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
+HOMEPAGE="http://tinyca.sm-zone.net/"
+SRC_URI="http://tinyca.sm-zone.net/${MY_P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/openssl-0.9.7e
+ dev-perl/Locale-gettext
+ >=virtual/perl-MIME-Base64-2.12
+ dev-perl/gtk2-perl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-compositefix.patch"
+ sed -i -e 's:./lib:/usr/share/tinyca/lib:g' \
+ -e 's:./templates:/usr/share/tinyca/templates:g' \
+ -e 's:./locale:/usr/share/locale:g' "${S}/tinyca2"
+}
+
+src_compile() {
+ make -C po
+}
+
+locale_install() {
+ dodir /usr/share/locale/$@/LC_MESSAGES/
+ insinto /usr/share/locale/$@/LC_MESSAGES/
+ doins locale/$@/LC_MESSAGES/tinyca2.mo
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe tinyca2 tinyca
+ insinto /usr/share/tinyca/lib
+ doins lib/*.pm
+ insinto /usr/share/tinyca/lib/GUI
+ doins lib/GUI/*.pm
+ insinto /usr/share/tinyca/templates
+ doins templates/*
+ insinto /usr/share/
+ strip-linguas de cs es
+ use linguas_de && locale_install de
+ use linguas_cs && locale_install cs
+ use linguas_es && locale_install es
+}