summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/files/digest-nano-1.2.51
-rw-r--r--app-editors/nano/nano-1.2.5.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 654a02004987..e60875548367 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.70 2005/04/14 03:24:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.71 2005/05/18 02:58:29 vapier Exp $
+
+*nano-1.2.5 (18 May 2005)
+
+ 18 May 2005; Mike Frysinger <vapier@gentoo.org> +nano-1.2.5.ebuild:
+ Version bump.
*nano-1.3.7 (14 Apr 2005)
diff --git a/app-editors/nano/files/digest-nano-1.2.5 b/app-editors/nano/files/digest-nano-1.2.5
new file mode 100644
index 000000000000..614ecdcc8cd9
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.2.5
@@ -0,0 +1 @@
+MD5 f2b3efbf1cf356d736740d531b6b22c4 nano-1.2.5.tar.gz 911938
diff --git a/app-editors/nano/nano-1.2.5.ebuild b/app-editors/nano/nano-1.2.5.ebuild
new file mode 100644
index 000000000000..3d0f9fef2af7
--- /dev/null
+++ b/app-editors/nano/nano-1.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.5.ebuild,v 1.1 2005/05/18 02:58:29 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86"
+IUSE="nls build spell justify debug slang ncurses"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ slang? ( sys-libs/slang )"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ $(use_enable justify) \
+ $(use_enable spell) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use build ; then
+ rm -r "${D}"/usr/share
+ else
+ cat "${FILESDIR}"/nanorc-* >> nanorc.sample
+ dodoc ChangeLog README nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}