summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/pose')
-rw-r--r--app-emulation/pose/ChangeLog7
-rw-r--r--app-emulation/pose/files/digest-pose-3.5-r41
-rw-r--r--app-emulation/pose/pose-3.5-r3.ebuild6
-rw-r--r--app-emulation/pose/pose-3.5-r4.ebuild85
4 files changed, 93 insertions, 6 deletions
diff --git a/app-emulation/pose/ChangeLog b/app-emulation/pose/ChangeLog
index 138f7f2a7d4d..b49aa8ae29b8 100644
--- a/app-emulation/pose/ChangeLog
+++ b/app-emulation/pose/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for app-emulation/pose
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/ChangeLog,v 1.10 2004/01/31 00:25:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/ChangeLog,v 1.11 2004/01/31 03:03:34 george Exp $
- 30 Jan 2004; George Shapovalov <george@gentoo.org> pose-3.5-r3.ebuild :
+*pose-3.5-r4 (30 Jan 2004)
+
+ 30 Jan 2004; George Shapovalov <george@gentoo.org> pose-3.5-r4.ebuild :
a fix for the "touchscreen clicks" problem (#5219),
thanks to Jake Hamby <jhamby@naobject.com> for spotiing it and the solution
+ (a run-time problem, so another revision bump..)
*pose-3.5-r3 (26 Jan 2004)
diff --git a/app-emulation/pose/files/digest-pose-3.5-r4 b/app-emulation/pose/files/digest-pose-3.5-r4
new file mode 100644
index 000000000000..6f7eb38e3cc3
--- /dev/null
+++ b/app-emulation/pose/files/digest-pose-3.5-r4
@@ -0,0 +1 @@
+MD5 c69b10798e524b999739bf1950125655 emulator_src_3.5.tar.gz 3162363
diff --git a/app-emulation/pose/pose-3.5-r3.ebuild b/app-emulation/pose/pose-3.5-r3.ebuild
index f231a028cfff..bd7ba0c1da85 100644
--- a/app-emulation/pose/pose-3.5-r3.ebuild
+++ b/app-emulation/pose/pose-3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/pose-3.5-r3.ebuild,v 1.2 2004/01/31 00:25:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/pose-3.5-r3.ebuild,v 1.3 2004/01/31 03:03:36 george Exp $
S=${WORKDIR}/Emulator_Src_3.5
HOMEPAGE="http://www.palmos.com/dev/tools/emulator/"
@@ -29,9 +29,7 @@ src_unpack() {
aclocal
automake --foreign
autoconf
- #package build scripts dp not honor C[XX]FLAGS, will have to do corrections via sed here..
- sed -i -e "s:-DPLATFORM_UNIX:-DFLTK_1_0_COMPAT -DPLATFORM_UNIX:" \
- -e "s:-O2:-O2 -fno-strict-aliasing:" configure
+ sed -i -e "s:-DPLATFORM_UNIX:-DFLTK_1_0_COMPAT -DPLATFORM_UNIX:" configure
cd ${S}
mkdir install-fltk
diff --git a/app-emulation/pose/pose-3.5-r4.ebuild b/app-emulation/pose/pose-3.5-r4.ebuild
new file mode 100644
index 000000000000..859b4e99d208
--- /dev/null
+++ b/app-emulation/pose/pose-3.5-r4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/pose-3.5-r4.ebuild,v 1.1 2004/01/31 03:03:36 george Exp $
+
+S=${WORKDIR}/Emulator_Src_3.5
+HOMEPAGE="http://www.palmos.com/dev/tools/emulator/"
+SRC_URI="http://www.palmos.com/dev/tools/emulator/sources/emulator_src_3.5.tar.gz"
+
+DESCRIPTION="Palm OS Emulator"
+
+DEPEND=">=x11-libs/fltk-1.1.4"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack emulator_src_3.5.tar.gz
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/detect-fluid.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/separate-builddir.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/choose-gl.diff || die "Patching failed"
+ patch -p0 < ${FILESDIR}/init-clipwidget.diff || die "Patching failed"
+ bzcat ${FILESDIR}/gcc-3.3_fix.diff.bz2 | patch -p1 || die "Patching failed"
+
+ cd ${S}/BuildUnix
+ aclocal
+ automake --foreign
+ autoconf
+ #package build scripts dp not honor C[XX]FLAGS, will have to do corrections via sed here..
+ sed -i -e "s:-DPLATFORM_UNIX:-DFLTK_1_0_COMPAT -DPLATFORM_UNIX:" \
+ -e "s:-O2:-O2 -fno-strict-aliasing:" configure
+
+ cd ${S}
+ mkdir install-fltk
+ ln -s /usr/include/fltk-1.1 install-fltk/include
+ ln -s /usr/lib/fltk-1.1 install-fltk/lib
+ mkdir static-libs
+ mkdir build-normal
+# mkdir build-profile
+
+ cd ${S}/static-libs
+ ln -sf `g++ -print-file-name=libstdc++.a` libstdc++.a
+}
+
+src_compile() {
+ cd ${S}/build-normal
+# cd ${S}/BuildUnix
+ LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+ --with-fltk=${S}/install-fltk \
+ --disable-gl || die
+
+ make || die
+
+# cd ${S}/build-profile
+# LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+# --with-fltk=${S}/install-fltk \
+# --disable-gl --enable-palm-profile || die
+#
+# make || die
+}
+
+src_install() {
+ cd ${S}/build-normal
+ dobin pose
+
+# cd ${S}/build-profile
+# newbin pose pose-profile
+
+ cd ${S}/Docs
+ dodoc *.txt *.rtf
+ dohtml *.html
+ insinto /usr/share/doc/${PF}
+ doins *.pdf
+
+ dodir /usr/share/pose/downloads
+ dodir /usr/share/pose/roms
+
+ cd ${S}/ROMTransfer/Source
+ insinto /usr/share/pose/downloads
+ doins *.prc
+}
+