summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/canna/ChangeLog8
-rw-r--r--app-i18n/canna/canna-3.6-r1.ebuild40
-rw-r--r--app-i18n/canna/files/canna-3.6-r1-gentoo.diff382
-rw-r--r--app-i18n/canna/files/digest-canna-3.6-r11
4 files changed, 430 insertions, 1 deletions
diff --git a/app-i18n/canna/ChangeLog b/app-i18n/canna/ChangeLog
index fc490ad27f82..93d64264fb13 100644
--- a/app-i18n/canna/ChangeLog
+++ b/app-i18n/canna/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/canna
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/ChangeLog,v 1.6 2002/11/18 09:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/ChangeLog,v 1.7 2002/12/02 14:41:51 nakano Exp $
+
+*canna-3.6-r1 (02 Dec 2002)
+ 02 Dec 2002; Masatomo Nakano <nakano@gentoo.org> canna-3.6-r1.ebuild
+ files/canna-3.6-r1-gentoo.diff ChangeLog :
+
+ fixed security bug.
*canna-3.6 (16 Nov 2002)
diff --git a/app-i18n/canna/canna-3.6-r1.ebuild b/app-i18n/canna/canna-3.6-r1.ebuild
new file mode 100644
index 000000000000..7687c5b314fe
--- /dev/null
+++ b/app-i18n/canna/canna-3.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6-r1.ebuild,v 1.1 2002/12/02 14:41:51 nakano Exp $
+
+MY_P="Canna36p1"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A client-server based Kana-Kanji conversion system"
+HOMEPAGE="http://canna.sourceforge.jp/"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+SRC_URI="http://downloads.sourceforge.jp/canna/1722/${MY_P}.tar.gz"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+
+ xmkmf || die
+ make Makefiles || die
+ # make includes
+ make canna || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install.man || die
+ dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/canna.initd canna || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/canna.confd canna || die
+}
+
diff --git a/app-i18n/canna/files/canna-3.6-r1-gentoo.diff b/app-i18n/canna/files/canna-3.6-r1-gentoo.diff
new file mode 100644
index 000000000000..6031d8b7483e
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.6-r1-gentoo.diff
@@ -0,0 +1,382 @@
+diff -Naur Canna36p1.orig/Canna.conf Canna36p1/Canna.conf
+--- Canna36p1.orig/Canna.conf 2002-12-02 09:44:59.000000000 +0900
++++ Canna36p1/Canna.conf 2002-12-02 22:03:25.000000000 +0900
+@@ -132,20 +132,26 @@
+
+ /* rootにならずにインストールする時はこれを定義して下さい */
+ /* #define InstallAsUser */
+-cannaPrefix = /usr/local/canna
++cannaPrefix = /usr
+ cannaExecPrefix = $(cannaPrefix)
+ cannaBinDir = $(cannaExecPrefix)/bin
+-cannaSrvDir = $(cannaExecPrefix)/bin
+-cannaLibDir = $(cannaPrefix)/lib
+-cannaManDir = $(cannaPrefix)/man
++cannaSrvDir = $(cannaExecPrefix)/sbin
++cannaLibDir = /etc/canna
++cannaEtcDir = /etc/canna
++cannaManDir = $(cannaPrefix)/share/man
+ cannaIncDir = $(cannaPrefix)/include/canna
++cannaDocDir = $(cannaPrefix)/share/doc/canna-3.6
++cannaShareDir = $(cannaPrefix)/share/canna
++
++LockDir = /tmp/.iroha_unix
++LockFile = IROHA
+
+ #ifdef InstallAsUser
+ libCannaDir = $(cannaExecPrefix)/lib
+ ErrDir = $(cannaExecPrefix)/log
+ #else
+ libCannaDir = /usr/lib
+-ErrDir = /usr/spool/canna
++ErrDir = /var/log/canna
+ #endif
+
+ /* 次の3行は変更しないでください */
+@@ -164,7 +170,7 @@
+
+ pointerIntegerDef =
+
+-cannaDsoRev = 1
++cannaDsoRev = 1.0
+ /* SunOS 4.x をお使いの方で shared object を利用する場合には
+ cannaDsoRev = 1.1
+ と指定してください。また、FreeBSD を利用する場合は、
+@@ -231,7 +237,7 @@
+ /* #define UseInstalledLibCanna YES */
+ #define UseInstalledLibCanna NO
+
+-DicDir = $(cannaLibDir)/dic
++DicDir = /var/lib/canna/dic
+
+ #ifdef NeXT
+ #define NO_X_ENV
+@@ -348,6 +354,9 @@
+ echo "s%@(UnixSockDir)%$(UnixSockDir)%g"; \ @@\
+ echo "s%@(UnixSockName)%$(UnixSockName)%g"; \ @@\
+ echo "s%@(AccessFile)%$(AccessFile)%g"; \ @@\
++ echo "s%@(DicDir)%$(DicDir)%g"; \ @@\
++ echo "s%@(LockDir)%$(LockDir)%g"; \ @@\
++ echo "s%@(LockFile)%$(LockFile)%g"; \ @@\
+ echo "s%@(ErrDir)%$(ErrDir)%g") > $(MANUALSED) @@\
+ clean:: @@\
+ $(RM) $(MANUALSED)
+@@ -364,11 +373,16 @@
+ echo "s%@(UnixSockDir)%$(UnixSockDir)%g" >> $(MANUALSED) @@\
+ echo "s%@(UnixSockName)%$(UnixSockName)%g" >> $(MANUALSED) @@\
+ echo "s%@(AccessFile)%$(AccessFile)%g" >> $(MANUALSED) @@\
++ echo "s%@(DicDir)%$(DicDir)%g" >> $(MANUALSED) @@\
++ echo "s%@(LockDir)%$(LockDir)%g" >> $(MANUALSED) @@\
++ echo "s%@(LockFile)%$(LockFile)%g" >> $(MANUALSED) @@\
+ echo "s%@(ErrDir)%$(ErrDir)%g" >> $(MANUALSED) @@\
+ clean:: @@\
+ $(RM) $(MANUALSED)
+ #endif
+
++MANSUFFIX = 1 /* man section for user programs */
++
+ #ifdef InstallManPageLong
+ #undef InstallManPageLong
+ #endif
+@@ -401,6 +415,8 @@
+ #define InstallManPage(file,destdir) @@\
+ InstallManPageLong(file,destdir,file)
+
++LIBMANSUFFIX = 3 /* man section for libraries */
++
+ #ifdef InstallLibManPageLong
+ #undef InstallLibManPageLong
+ #endif
+@@ -527,6 +543,7 @@
+ echo "#define CANNAHOSTFILE '$(cannaLibDir)/cannahost'" >> junk @@\
+ echo "/* for lib/canna */" >> junk @@\
+ echo "#define CANNALIBDIR '$(cannaLibDir)'" >> junk @@\
++ echo "#define CANNASHAREDIR '$(cannaShareDir)'" >> junk @@\
+ echo "/* for scripts */" >> junk @@\
+ echo "#define CANNABINDIR $(cannaBinDir)" >> junk @@\
+ echo "/* others */" >> junk @@\
+@@ -553,6 +570,7 @@
+ echo "#define CANNAHOSTFILE \"$(cannaLibDir)/cannahost\"";\ @@\
+ echo "/* for lib/canna */";\ @@\
+ echo "#define CANNALIBDIR \"$(cannaLibDir)\""; \ @@\
++ echo "#define CANNASHAREDIR \"$(cannaShareDir)\""; \ @@\
+ echo "/* for scripts */";\ @@\
+ echo "#define CANNABINDIR $(cannaBinDir)"; \ @@\
+ echo "/* others */";\ @@\
+diff -Naur Canna36p1.orig/cmd/catdic/Imakefile Canna36p1/cmd/catdic/Imakefile
+--- Canna36p1.orig/cmd/catdic/Imakefile 2002-11-07 23:46:02.000000000 +0900
++++ Canna36p1/cmd/catdic/Imakefile 2002-12-02 22:03:25.000000000 +0900
+@@ -1,6 +1,9 @@
+ /* $Id: canna-3.6-r1-gentoo.diff,v 1.1 2002/12/02 14:41:51 nakano Exp $ */
+ #include "../../Canna.conf"
+
++/* gentoo: use hard links so that the image can be merged correctly */
++ LN = ln
++
+ CANNAROOT = ../..
+ CANNASRC = $(CANNAROOT)/lib/canna
+ RKCSRC = $(CANNAROOT)/lib/RKC
+diff -Naur Canna36p1.orig/cmd/catdic/cannakill.man Canna36p1/cmd/catdic/cannakill.man
+--- Canna36p1.orig/cmd/catdic/cannakill.man 2002-10-23 00:19:13.000000000 +0900
++++ Canna36p1/cmd/catdic/cannakill.man 2002-12-02 22:03:25.000000000 +0900
+@@ -29,14 +29,14 @@
+ .SH "DESCRIPTION"
+ .PP
+ cannakill terminates operation of Kana-Kanji conversion server
+-cannaserver(1M). This causes the server to delete the socket and
++cannaserver(1). This causes the server to delete the socket and
+ close all open dictionaries before terminating its processing.
+ .PP
+-The user who has started cannaserver(1M) or the super user can only
+-use cannakill(1M) to terminate operation of canncannaer.
++The user who has started cannaserver(1) or the super user can only
++use cannakill(1) to terminate operation of canncannaer.
+ .SH "FILES"
+ .IP "@(UnixSockDir)/@(UnixSockName)[:num]" 36
+ Socket
+ .SH "SEE ALSO"
+ .PP
+-cannaserver(1M), cannastat(1), cannacheck(1)
++cannaserver(1), cannastat(1), cannacheck(1)
+diff -Naur Canna36p1.orig/cmd/catdic/catdic.man Canna36p1/cmd/catdic/catdic.man
+--- Canna36p1.orig/cmd/catdic/catdic.man 2002-10-19 17:27:33.000000000 +0900
++++ Canna36p1/cmd/catdic/catdic.man 2002-12-02 22:03:25.000000000 +0900
+@@ -30,7 +30,7 @@
+ catdic downloads a dictionary file to the current directory.
+ The file downloaded is a dictionary file the dictionary name of which is
+ \fIremote-dic\fP. It is in the user dictionary directory of the machine
+-on which \fIcannaserver\fP(1M) is in operation. (Hereafter, this machine
++on which \fIcannaserver\fP(1) is in operation. (Hereafter, this machine
+ is called the remote host.)
+ .SH "OPTIONS"
+ .IP "\-cs \fIcanna-server\fP (or \-cannaserver \fIcanna-server\fP)" 12
+@@ -61,4 +61,4 @@
+ file ``test2.t''.
+ .SH "SEE ALSO"
+ .PP
+-cannaserver(1M), lsdic(1), mkdic(1)
++cannaserver(1), lsdic(1), mkdic(1)
+diff -Naur Canna36p1.orig/cmd/catdic/mkdic.man Canna36p1/cmd/catdic/mkdic.man
+--- Canna36p1.orig/cmd/catdic/mkdic.man 2002-10-19 17:27:33.000000000 +0900
++++ Canna36p1/cmd/catdic/mkdic.man 2002-12-02 22:03:25.000000000 +0900
+@@ -28,7 +28,7 @@
+ .SH "DESCRIPTION"
+ .PP
+ mkdic creates user dictionary named \fIremote-dic\fP in the user dictionary
+-directory of the remote host, on which \fIcannaserver\fP(1M) is in operation.
++directory of the remote host, on which \fIcannaserver\fP(1) is in operation.
+ Dictionary file name \fIremote-dic\fP is assigned to this file at this time.
+ .PP
+ If the \- and \-l option isn't specified, mkdic creates an empty dictionary.
+@@ -96,4 +96,4 @@
+ user1.t is a dictionary file name generated automatically by the system.
+ .SH "SEE ALSO"
+ .PP
+-catdic(1), cannaserver(1M), lsdic(1)
++catdic(1), cannaserver(1), lsdic(1)
+diff -Naur Canna36p1.orig/cmd/cshost/cshost.man Canna36p1/cmd/cshost/cshost.man
+--- Canna36p1.orig/cmd/cshost/cshost.man 2002-10-19 17:27:34.000000000 +0900
++++ Canna36p1/cmd/cshost/cshost.man 2002-12-02 22:03:25.000000000 +0900
+@@ -6,9 +6,9 @@
+ .SH "DESCRIPTION"
+ .PP
+ the \fIcshost\fP(1) prints the list of machines that are allowed to make
+-connections to \fIcannaserver\fP(1M).
++connections to \fIcannaserver\fP(1).
+ .PP
+-\fIcannaserver\fP(1M) allows network connections only from programs
++\fIcannaserver\fP(1) allows network connections only from programs
+ running on the same machine or machines listed in the file
+ /etc/hosts.canna. If /etc/hosts.canna does not exist or the file
+ is empty, access is granted to everyone.
+diff -Naur Canna36p1.orig/dic/ideo/grammar/Imakefile Canna36p1/dic/ideo/grammar/Imakefile
+--- Canna36p1.orig/dic/ideo/grammar/Imakefile 2002-10-19 17:27:34.000000000 +0900
++++ Canna36p1/dic/ideo/grammar/Imakefile 2002-12-02 22:03:25.000000000 +0900
+@@ -85,6 +85,6 @@
+ InstallMultipleFlags($(ALLDIC),$(CANNADICDIR),-m 0664 $(cannaOwnerGroup))
+
+ install::
+- $(CHGRP) $(cannaGroup) $(CANNADICDIR)
+- $(CHOWN) $(cannaOwner) $(CANNADICDIR)
+- $(CHMOD) ug+w $(CANNADICDIR)
++ $(CHGRP) $(cannaGroup) $(DESTDIR)$(CANNADICDIR)
++ $(CHOWN) $(cannaOwner) $(DESTDIR)$(CANNADICDIR)
++ $(CHMOD) ug+w $(DESTDIR)$(CANNADICDIR)
+diff -Naur Canna36p1.orig/dic/phono/Imakefile Canna36p1/dic/phono/Imakefile
+--- Canna36p1.orig/dic/phono/Imakefile 2002-10-19 17:27:40.000000000 +0900
++++ Canna36p1/dic/phono/Imakefile 2002-12-02 22:03:32.000000000 +0900
+@@ -27,9 +27,10 @@
+
+ ROMAJI_DIC_DEF = -DSHIFT
+
+- DICDIR = $(cannaLibDir)/dic
+- SAMPLEDIR = $(cannaLibDir)/sample
+- SAMPLESRCDIR = $(cannaLibDir)/sample/src
++ DICDIR = $(DicDir)
++ CANNASHAREDIR = $(cannaShareDir)
++ SAMPLEDIR = $(cannaDocDir)/sample
++ SAMPLESRCDIR = $(cannaDocDir)/sample/src
+
+ KPDEF = default.kpdef jdaemon.kpdef just.kpdef kaisoku.kpdef kana.kpdef \
+ lan5.kpdef matsu.kpdef newjis.kpdef romaji.kpdef sokuon.kpdef \
+@@ -69,7 +70,7 @@
+ MakeDirectories(install,$(DICDIR))
+ MakeDirectories(install,$(SAMPLESRCDIR))
+
+-InstallMultiple($(ROMKANA_TABLES),$(DICDIR))
++InstallMultiple($(ROMKANA_TABLES),$(CANNASHAREDIR))
+
+ #ifdef USE_OBSOLETE_STYLE_FILENAME
+ InstallNonExec(default.kpdef,$(SAMPLESRCDIR))
+diff -Naur Canna36p1.orig/lib/canna/Imakefile Canna36p1/lib/canna/Imakefile
+--- Canna36p1.orig/lib/canna/Imakefile 2002-10-20 17:20:33.000000000 +0900
++++ Canna36p1/lib/canna/Imakefile 2002-12-02 22:03:32.000000000 +0900
+@@ -116,8 +116,8 @@
+ #endif /* ProjectX */
+ #endif /* DoSharedLib */
+
+-sglobal.h: GSYM.awk globnames
+- awk -f GSYM.awk < globnames > $@
++includes::
++ awk -f GSYM.awk < globnames > sglobal.h
+
+ clean::
+ $(RM) y.tab.h y.tab.c lex.yy.c gram.h gram.c lex.c sglobal.h
+diff -Naur Canna36p1.orig/lib/canna/ebind.c Canna36p1/lib/canna/ebind.c
+--- Canna36p1.orig/lib/canna/ebind.c 2002-10-19 17:27:48.000000000 +0900
++++ Canna36p1/lib/canna/ebind.c 2002-12-02 22:03:32.000000000 +0900
+@@ -205,9 +205,9 @@
+ }
+ }
+
+- inbuf[0] = (wchar_t)buffer_return[0];
++ inbuf[0] = (wchar_t)(buffer_return[0] & 0xff);
+ for (i = 1 ; i < nbytes ; i++) {
+- inbuf[i] = (wchar_t)buffer_return[i];
++ inbuf[i] = (wchar_t)(buffer_return[i] & 0xff);
+ }
+ ch = buffer_return[0] & 0xff;
+ ret = XwcLookupKanji2(dpy, win, inbuf, inbufsize, nbytes, functionalChar,
+diff -Naur Canna36p1.orig/lib/canna/romaji.c Canna36p1/lib/canna/romaji.c
+--- Canna36p1.orig/lib/canna/romaji.c 2002-10-21 03:00:21.000000000 +0900
++++ Canna36p1/lib/canna/romaji.c 2002-12-02 22:03:32.000000000 +0900
+@@ -438,7 +438,7 @@
+ }
+ }
+
+-#if 0 /* currently CANNASHAREDDIR is not defined */
++#if 1 /* currently CANNASHAREDDIR is defined */
+ if (retval == (struct RkRxDic *)NULL) { /* added for Debian by ISHIKAWA Mutsumi <ishikawa@linux.or.jp> */
+ extern jrUserInfoStruct *uinfo;
+
+diff -Naur Canna36p1.orig/misc/Imakefile Canna36p1/misc/Imakefile
+--- Canna36p1.orig/misc/Imakefile 2002-10-21 03:00:21.000000000 +0900
++++ Canna36p1/misc/Imakefile 2002-12-02 22:03:32.000000000 +0900
+@@ -34,11 +34,11 @@
+ MakeLintLibSubdirs($(SUBDIRS))
+ MakeLintSubdirs($(SUBDIRS),install.ln,install.ln)
+
+-MakeDirectories(install,$(cannaLibDir)/sample/src)
++MakeDirectories(install,$(cannaDocDir)/sample/src)
+ #if defined(nec_ews_svr4) || defined(pcux_r32)
+-InstallNamedNonExec(rMakefile,Makefile,$(cannaLibDir)/sample/src)
++InstallNamedNonExec(rMakefile,Makefile,$(cannaDocDir)/sample/src)
+ #else
+-InstallNamedNonExec(cMakefile,Makefile,$(cannaLibDir)/sample/src)
++InstallNamedNonExec(cMakefile,Makefile,$(cannaDocDir)/sample/src)
+ #endif /* nec_ews_svr4 */
+
+ #ifdef USE_OBSOLETE_STYLE_FILENAME
+@@ -49,8 +49,8 @@
+ $(CP) default.ca default.canna
+ #endif
+
+-InstallNonExec(default.canna,$(cannaLibDir))
+-InstallNonExec(is.c,$(cannaLibDir)/sample/src)
++InstallNonExec(default.canna,$(cannaEtcDir))
++InstallNonExec(is.c,$(cannaDocDir)/sample/src)
+
+ clean::
+ $(RM) $(PROGRAMS)
+diff -Naur Canna36p1.orig/misc/initfiles/Imakefile Canna36p1/misc/initfiles/Imakefile
+--- Canna36p1.orig/misc/initfiles/Imakefile 2002-10-19 17:27:52.000000000 +0900
++++ Canna36p1/misc/initfiles/Imakefile 2002-12-02 22:03:32.000000000 +0900
+@@ -6,7 +6,7 @@
+ #endif
+
+ CANNAROOT = ../..
+- SAMPLEDIR = $(cannaLibDir)/sample
++ SAMPLEDIR = $(cannaShareDir)
+
+ all::
+
+diff -Naur Canna36p1.orig/server/server.man Canna36p1/server/server.man
+--- Canna36p1.orig/server/server.man 2002-11-01 17:32:06.000000000 +0900
++++ Canna36p1/server/server.man 2002-12-02 22:09:56.000000000 +0900
+@@ -28,19 +28,19 @@
+ .SH "DESCRIPTION"
+ .PP
+ cannaserver provides the Kana-Kanji conversion service. Usually all
+-users on the network can access cannaserver(1M). The scope of
++users on the network can access cannaserver(1). The scope of
+ accessing sources (hosts, users) can be restricted using the
+ /etc/hosts.canna file.
+ .PP
+-After starting, cannaserver(1M) immediately forks and enters the
++After starting, cannaserver(1) immediately forks and enters the
+ background process. Thus, you do not need to use '&' to set the
+ background process explicitly.
+ .PP
+-When starting, cannaserver(1M) creates the UNIX domain socket
++When starting, cannaserver(1) creates the UNIX domain socket
+ @(UnixSockDir)/@(UnixSockName) to communicate clients. The
+-socket is deleted automatically at the end of cannaserver(1M) if no
+-trouble occurs. The socket may exist although cannaserver(1M) is
+-not in operation (because cannaserver(1M) terminates abnormally, for
++socket is deleted automatically at the end of cannaserver(1) if no
++trouble occurs. The socket may exist although cannaserver(1) is
++not in operation (because cannaserver(1) terminates abnormally, for
+ example). In this case, delete the file manually.
+ .PP
+ Specification of the dictionary to use is determined by referencing
+@@ -50,25 +50,25 @@
+ .IP "\fIddpath\fP" 12
+ Specifies the directory that contains the dictionary.
+ .IP "\-inet" 12
+-The remote host can connect with the cannaserver(1M) using
++The remote host can connect with the cannaserver(1) using
+ the inet domain socket.
+-By the default, the cannaserver(1M) uses only UNIX domain socket.
++By the default, the cannaserver(1) uses only UNIX domain socket.
+ i.e. Only clients in your local machine can connect to the server.
+ .IP "\-l \fIn\fP" 12
+-Outputs the cannaserver(1M) log to /tmp/canna.log. n (1 to 5)
++Outputs the cannaserver(1) log to /tmp/canna.log. n (1 to 5)
+ specifies the log level.
+ .IP "\-d" 12
+-Starts cannaserver(1M) in debug mode. It is executed as the
++Starts cannaserver(1) in debug mode. It is executed as the
+ foreground process. Log data at log level 5 is output to the standard
+ output.
+ .IP "\-u \fIuserid\fP" 12
+-Specifies which user cannaserver(1M) runs as. By default, cannaserver(1M)
+-runs as the user who started cannaserver(1M).
++Specifies which user cannaserver(1) runs as. By default, cannaserver(1)
++runs as the user who started cannaserver(1).
+ .IP "\-syslog" 12
+-Outputs the cannaserver(1M) log to syslogd(8).
++Outputs the cannaserver(1) log to syslogd(8).
+ .IP "\-p \fInum\fP" 12
+-If specified, cannaserver(1M) will use the port number 5680 + num. By
+-default, cannaserver(1M) uses the port number 5680.
++If specified, cannaserver(1) will use the port number 5680 + num. By
++default, cannaserver(1) uses the port number 5680.
+ .SH "FILES"
+ .IP "@(UnixSockDir)/@(UnixSockName)[:num]" 36
+ Socket
+@@ -78,4 +78,4 @@
+ Access control file
+ .SH "SEE ALSO"
+ .PP
+-cannakill(1M), cannastat(1), cannacheck(1)
++cannakill(1), cannastat(1), cannacheck(1)
diff --git a/app-i18n/canna/files/digest-canna-3.6-r1 b/app-i18n/canna/files/digest-canna-3.6-r1
new file mode 100644
index 000000000000..3465be2b43cb
--- /dev/null
+++ b/app-i18n/canna/files/digest-canna-3.6-r1
@@ -0,0 +1 @@
+MD5 303f236f40f923c9c3f3cdde90561ddc Canna36p1.tar.gz 1337483