summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/jing/ChangeLog11
-rw-r--r--app-text/jing/files/build-r1.xml34
-rw-r--r--app-text/jing/files/digest-jing-20030619-r33
-rw-r--r--app-text/jing/jing-20030619-r3.ebuild75
4 files changed, 121 insertions, 2 deletions
diff --git a/app-text/jing/ChangeLog b/app-text/jing/ChangeLog
index 5c7562be9d52..2df3c68c8bd4 100644
--- a/app-text/jing/ChangeLog
+++ b/app-text/jing/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/jing
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.15 2006/12/03 17:28:49 nichoj Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.16 2007/01/20 19:57:26 betelgeuse Exp $
+
+*jing-20030619-r3 (20 Jan 2007)
+
+ 20 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> +files/build-r1.xml,
+ +jing-20030619-r3.ebuild:
+ Fixed bug #122038, made this compile with jdks >=1.5, cleaned the ebuild and
+ added the source use flag.
*jing-20030619-r2 (03 Dec 2006)
diff --git a/app-text/jing/files/build-r1.xml b/app-text/jing/files/build-r1.xml
new file mode 100644
index 000000000000..8de4f9ad16ae
--- /dev/null
+++ b/app-text/jing/files/build-r1.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0"?>
+
+<project name="jing" default="jar">
+ <!-- compiles the sources -->
+ <target name="compile">
+ <mkdir dir="build" />
+
+ <javac srcdir="src"
+ destdir="build"
+ source="1.4">
+ <classpath>
+ <fileset dir="bin" includes="*.jar"/>
+ </classpath>
+ </javac>
+
+ <!-- we need the *.properties at the correct
+ position in the jar archive! -->
+ <copy todir="build">
+ <fileset dir="src">
+ <include name="**/*.properties" />
+ </fileset>
+ </copy>
+ <copy todir="build/META-INF">
+ <fileset dir="src/META-INF" />
+ </copy>
+ </target>
+
+ <!-- create the jar archive -->
+ <target name="jar" depends="compile">
+ <jar jarfile="bin/jing.jar"
+ basedir="build">
+ </jar>
+ </target>
+</project>
diff --git a/app-text/jing/files/digest-jing-20030619-r3 b/app-text/jing/files/digest-jing-20030619-r3
new file mode 100644
index 000000000000..00777af6daec
--- /dev/null
+++ b/app-text/jing/files/digest-jing-20030619-r3
@@ -0,0 +1,3 @@
+MD5 f9b0775d8740f16ab3df82ad3707a093 jing-20030619.zip 2523368
+RMD160 53ae68b42bee829f3e6da910c5a96e9910cfa430 jing-20030619.zip 2523368
+SHA256 b10a7fbbf1f5354de59700a1665f27d68a71b07f6927c2e497dc0ba294a47efd jing-20030619.zip 2523368
diff --git a/app-text/jing/jing-20030619-r3.ebuild b/app-text/jing/jing-20030619-r3.ebuild
new file mode 100644
index 000000000000..8fc1e71b64f0
--- /dev/null
+++ b/app-text/jing/jing-20030619-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20030619-r3.ebuild,v 1.1 2007/01/20 19:57:26 betelgeuse Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Jing: A RELAX NG validator in Java"
+HOMEPAGE="http://thaiopensource.com/relaxng/jing.html"
+SRC_URI="http://www.thaiopensource.com/download/${P}.zip"
+LICENSE="BSD Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source"
+COMMON_DEPEND="
+ =dev-java/saxon-8*
+ >=dev-java/xerces-2.7
+ dev-java/iso-relax
+ dev-java/relaxng-datatype"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp ${FILESDIR}/build-r1.xml build.xml || die
+
+ mkdir src/
+ cd src/
+ unpack ./../src.zip
+ # Has java.util.regex, xerces2 and xerces1 implementation
+ # We only need the first one
+ rm -vr com/thaiopensource/datatype/xsd/regex/{xerces,xerces2} || die
+ epatch ${FILESDIR}/build-patch.diff
+ epatch ${FILESDIR}/${P}-xerces.patch
+
+ #remove bundled relaxng-datatype
+ rm -r org
+
+ cd ../bin/
+ rm -v *.jar
+ java-pkg_jar-from iso-relax
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from xalan
+ java-pkg_jar-from saxon saxon8.jar saxon.jar
+ java-pkg_jar-from relaxng-datatype
+ java-pkg_jar-from ant-core
+}
+
+src_compile() {
+ eant jar #premade javadocs
+}
+
+src_test() {
+ local cp
+ for jar in bin/*.jar; do
+ cp="${cp}:${jar}"
+ done
+ # would need some test files could probably take this from the gcj version
+ #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.TestDriver || die
+ #java -cp ${cp} com.thaiopensource.datatype.relaxng.util.TestDriver || die
+ #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.CategoryTest \
+ # || die
+}
+
+src_install() {
+ java-pkg_dojar bin/jing.jar
+ java-pkg_dolauncher ${PN} --main com.thaiopensource.relaxng.util.Driver
+ use doc && java-pkg_dohtml -r doc/* readme.html
+ use source && java-pkg_dosrc src/com
+}