summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild')
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild
new file mode 100644
index 000000000000..defaad2eb019
--- /dev/null
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild,v 1.1 2006/03/04 00:00:36 ciaranm Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: enhanced comment creation"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=23"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="EnhancedCommentify"
+
+DEPEND="${DEPEND} >=sys-apps/sed-4"
+# bug #74897
+RDEPEND="!app-vim/ctx"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # gentooy things, bug #79185
+ epatch ${FILESDIR}/${PN}-2.1-gentooisms.patch
+ epatch ${FILESDIR}/${PN}-2.1-extra-ft-support.patch
+}