summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.0.1.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.0.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.0.1.ebuild
new file mode 100644
index 000000000000..a20de06e8414
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.0.1.ebuild,v 1.1 2003/11/06 16:42:25 nakano Exp $
+
+DESCRIPTION="wxWindows GUI for PostgreSQL"
+
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/src/${P}.tar.gz"
+LICENSE="Artistic"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Need 2.4.1-r1 for the extras in contrib
+DEPEND=">=wxGTK-2.4.1-r1
+ >=dev-db/postgresql-7.3"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die
+ cd ${S}/src
+ sed -i -e "s:^\(LIBS\).*:\1 = -lssl -lcrypto -lpq -lwx_gtk2-2.4 -lwx_gtk2_xrc-2.4 -lwx_gtk2_stc-2.4:" Makefile
+
+ cd ${S}
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}