summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gconf-sharp')
-rw-r--r--dev-dotnet/gconf-sharp/ChangeLog9
-rw-r--r--dev-dotnet/gconf-sharp/Manifest4
-rw-r--r--dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.102
-rw-r--r--dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.8-r12
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-1.0.10.ebuild27
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-1.0.8-r1.ebuild27
6 files changed, 70 insertions, 1 deletions
diff --git a/dev-dotnet/gconf-sharp/ChangeLog b/dev-dotnet/gconf-sharp/ChangeLog
index 12b2b9e39ef0..39a4cd8083ba 100644
--- a/dev-dotnet/gconf-sharp/ChangeLog
+++ b/dev-dotnet/gconf-sharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/gconf-sharp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.26 2005/05/21 16:30:34 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.27 2005/05/24 17:38:43 latexer Exp $
+
+*gconf-sharp-1.0.10 (24 May 2005)
+*gconf-sharp-1.0.8-r1 (24 May 2005)
+
+ 24 May 2005; Peter Johanson <latexer@gentoo.org>
+ +gconf-sharp-1.0.8-r1.ebuild, +gconf-sharp-1.0.10.ebuild:
+ Revision bump to force out pkg-config fix, and bump to latest 1.0.x release.
21 May 2005; Peter Johanson <latexer@gentoo.org> :
Digest of new diff that fixes bug #93433.
diff --git a/dev-dotnet/gconf-sharp/Manifest b/dev-dotnet/gconf-sharp/Manifest
index 8a2ed598b857..978b2b9a6381 100644
--- a/dev-dotnet/gconf-sharp/Manifest
+++ b/dev-dotnet/gconf-sharp/Manifest
@@ -5,8 +5,12 @@ MD5 36d7987983a4d7c872e86a28afa13b60 ChangeLog 2611
MD5 a60fdfbce7c7cfc52187ff86a7f8bbf8 metadata.xml 222
MD5 1045aac9ba99db8e3ff602f7d9acfe99 gconf-sharp-1.9.3.1.ebuild 829
MD5 79605244f9c69cce0c6a5531485bc883 gconf-sharp-1.9.5.ebuild 821
+MD5 d66be4570da4db99882d0de11aadbdcc gconf-sharp-1.0.8-r1.ebuild 790
+MD5 d66be4570da4db99882d0de11aadbdcc gconf-sharp-1.0.10.ebuild 790
MD5 d3c03463afacd40a934397a076f9bf9b files/digest-gconf-sharp-2.5.5 147
MD5 ff5a2a47c3e1d785fc179c922857e409 files/digest-gconf-sharp-1.0.6 147
MD5 fef3bd202b3f48969673897302f3be4c files/digest-gconf-sharp-1.0.8 147
+MD5 fef3bd202b3f48969673897302f3be4c files/digest-gconf-sharp-1.0.8-r1 147
MD5 fe4e7ed3578050079793d30322ad8a6c files/digest-gconf-sharp-1.9.3.1 151
MD5 2f754d97c9892c6b5cd78fb43433df9d files/digest-gconf-sharp-1.9.5 147
+MD5 302dbc192d1c69a0ba956625d73ef2c2 files/digest-gconf-sharp-1.0.10 149
diff --git a/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.10 b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.10
new file mode 100644
index 000000000000..2ba080c758a5
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.10
@@ -0,0 +1,2 @@
+MD5 e21fb3c5a39374f86ba70b926311a6d0 gtk-sharp-1.0.10.tar.gz 1841067
+MD5 dc56efe734ebf04b7649ea1992f1e982 gtk-sharp-1.0.10-configurable.diff.gz 1718
diff --git a/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.8-r1 b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.8-r1
new file mode 100644
index 000000000000..2e54ffd1c107
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.0.8-r1
@@ -0,0 +1,2 @@
+MD5 89d835b161e2f84604d1f4747e7ffda3 gtk-sharp-1.0.8.tar.gz 1841365
+MD5 c0771342aec18394c0366bbd0c07ae27 gtk-sharp-1.0.8-configurable.diff.gz 1506
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-1.0.10.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-1.0.10.ebuild
new file mode 100644
index 000000000000..c6598bbb6356
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-1.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-1.0.10.ebuild,v 1.1 2005/05/24 17:38:43 latexer Exp $
+
+inherit gtk-sharp-component
+
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.0
+ =dev-dotnet/gtk-sharp-${PV}*
+ =dev-dotnet/glade-sharp-${PV}*
+ =dev-dotnet/gnome-sharp-${PV}*
+ =dev-dotnet/art-sharp-${PV}*"
+
+GTK_SHARP_COMPONENT_BUILD="gnome"
+GTK_SHARP_COMPONENT_BUILD_DEPS="art"
+
+src_unpack() {
+ gtk-sharp-component_src_unpack
+
+ # Fix need as GConf.PropertyEditors references a locally built dll
+ sed -i "s:${GTK_SHARP_LIB_DIR}/gconf-sharp.dll:../GConf/gconf-sharp.dll:" \
+ ${S}/gconf/GConf.PropertyEditors/Makefile.in
+}
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-1.0.8-r1.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..76b41dc298b4
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-1.0.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-1.0.8-r1.ebuild,v 1.1 2005/05/24 17:38:43 latexer Exp $
+
+inherit gtk-sharp-component
+
+SLOT="1"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.0
+ =dev-dotnet/gtk-sharp-${PV}*
+ =dev-dotnet/glade-sharp-${PV}*
+ =dev-dotnet/gnome-sharp-${PV}*
+ =dev-dotnet/art-sharp-${PV}*"
+
+GTK_SHARP_COMPONENT_BUILD="gnome"
+GTK_SHARP_COMPONENT_BUILD_DEPS="art"
+
+src_unpack() {
+ gtk-sharp-component_src_unpack
+
+ # Fix need as GConf.PropertyEditors references a locally built dll
+ sed -i "s:${GTK_SHARP_LIB_DIR}/gconf-sharp.dll:../GConf/gconf-sharp.dll:" \
+ ${S}/gconf/GConf.PropertyEditors/Makefile.in
+}