summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haddock/haddock-2.4.1.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-2.4.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-haskell/haddock/haddock-2.4.1.ebuild b/dev-haskell/haddock/haddock-2.4.1.ebuild
index 7640fe8cdb99..8ed1842a89b6 100644
--- a/dev-haskell/haddock/haddock-2.4.1.ebuild
+++ b/dev-haskell/haddock/haddock-2.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.1.ebuild,v 1.8 2010/07/01 19:24:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.1.ebuild,v 1.9 2010/09/19 17:01:23 slyfox Exp $
CABAL_FEATURES="bin lib"
# don't enable profiling as the 'ghc' package is not built with profiling
-inherit haskell-cabal autotools
+inherit haskell-cabal autotools pax-utils
GHCPATHS_PN="ghc-paths"
GHCPATHS_PV="0.1.0.5"
@@ -78,6 +78,10 @@ src_compile () {
src_install () {
cabal_src_install
+ # haddock uses GHC-api to process TH source.
+ # TH requires GHCi which needs mmap('rwx') (bug #299709)
+ pax-mark -m "${D}/usr/bin/${PN}"
+
if use doc; then
dohtml -r "${S}/doc/haddock/"*
fi