summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-graph')
-rw-r--r--dev-java/commons-graph/ChangeLog11
-rw-r--r--dev-java/commons-graph/Manifest5
-rw-r--r--dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild64
-rw-r--r--dev-java/commons-graph/files/commons-graph-0.8.1_p20040118-gentoo.diff19
-rw-r--r--dev-java/commons-graph/files/digest-commons-graph-0.8.1_p200401181
-rw-r--r--dev-java/commons-graph/metadata.xml5
6 files changed, 105 insertions, 0 deletions
diff --git a/dev-java/commons-graph/ChangeLog b/dev-java/commons-graph/ChangeLog
new file mode 100644
index 000000000000..4bc16ef788a7
--- /dev/null
+++ b/dev-java/commons-graph/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/commons-graph
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/ChangeLog,v 1.1 2005/12/04 21:12:24 nichoj Exp $
+
+*commons-graph-0.8.1_p20040118 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/commons-graph-0.8.1_p20040118-gentoo.diff, +metadata.xml,
+ +commons-graph-0.8.1_p20040118.ebuild:
+ Initial import (bug #70892).
+
diff --git a/dev-java/commons-graph/Manifest b/dev-java/commons-graph/Manifest
new file mode 100644
index 000000000000..76f1e9320222
--- /dev/null
+++ b/dev-java/commons-graph/Manifest
@@ -0,0 +1,5 @@
+MD5 cea23d8a958f2b92f40497e4f60297c9 ChangeLog 359
+MD5 4521eb09d2383e54c663fa0a001b3032 commons-graph-0.8.1_p20040118.ebuild 1621
+MD5 361f23cd46c14f40fbb6590b564f20a5 files/commons-graph-0.8.1_p20040118-gentoo.diff 758
+MD5 bf85b87a012c334e20d661447bbf52b4 files/digest-commons-graph-0.8.1_p20040118 75
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild b/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
new file mode 100644
index 000000000000..a569cd687578
--- /dev/null
+++ b/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild,v 1.1 2005/12/04 21:12:24 nichoj Exp $
+
+inherit java-pkg eutils
+MY_PN=graph2
+MY_PV=${PV%%_*}.cvs${PV##*_p}
+MY_P=${MY_PN}-${MY_PV}
+DESCRIPTION="A toolkit for managing graphs and graph based data structures"
+# There doesn't seem to be a real home page
+HOMEPAGE="http://cvs.apache.org/viewcvs/jakarta-commons-sandbox/graph2/"
+# this was extracted from a source rpm at jpackage
+SRC_URI="mirror://gentoo/distfiles/${MY_P}.tar.gz"
+CDEPEND="dev-java/log4j
+ dev-java/commons-collections
+ dev-java/xerces"
+DEPEND=">=virtual/jdk-1.3
+ jikes? ( dev-java/jikes )
+ dev-java/ant-core
+ test? ( dev-java/ant-tasks )
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.3
+ ${CDEPEND}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes test"
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-collections
+ java-pkg_jar-from xerces-2 xml-apis.jar
+
+}
+
+src_compile(){
+ local antflags="jar -Dnoget=true"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "compile failed"
+}
+
+src_install(){
+ java-pkg_dojar target/commons-graph*.jar
+ use doc && java-pkg_dohtml -r dist/docs/api
+}
+
+src_test() {
+ if use test; then
+ local antflags="test -Dnoget=true"
+ ant ${antflags} || die "test failed"
+ else
+ ewarn "You must include 'test' in your use flags in order to"
+ ewarn "get the dependencies needed to run unit tests"
+ ewarn "Skipping unit tests"
+ fi
+}
diff --git a/dev-java/commons-graph/files/commons-graph-0.8.1_p20040118-gentoo.diff b/dev-java/commons-graph/files/commons-graph-0.8.1_p20040118-gentoo.diff
new file mode 100644
index 000000000000..c7ffe457a11e
--- /dev/null
+++ b/dev-java/commons-graph/files/commons-graph-0.8.1_p20040118-gentoo.diff
@@ -0,0 +1,19 @@
+diff -ru graph2-0.8.1.cvs20040118/build.xml graph2-0.8.1.cvs20040118-patched/build.xml
+--- graph2-0.8.1.cvs20040118/build.xml 2003-02-18 09:45:49.000000000 -0500
++++ graph2-0.8.1.cvs20040118-patched/build.xml 2005-09-04 22:44:31.000000000 -0400
+@@ -46,7 +47,7 @@
+ </classpath>
+ </javac>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
+@@ -162,4 +163,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118 b/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118
new file mode 100644
index 000000000000..9434bdca5399
--- /dev/null
+++ b/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118
@@ -0,0 +1 @@
+MD5 2f0b4b570e383321675e56d3a2bbfa08 graph2-0.8.1.cvs20040118.tar.gz 42653
diff --git a/dev-java/commons-graph/metadata.xml b/dev-java/commons-graph/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-graph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>