summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/beecrypt')
-rw-r--r--dev-libs/beecrypt/ChangeLog6
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.1.2-build.patch24
2 files changed, 23 insertions, 7 deletions
diff --git a/dev-libs/beecrypt/ChangeLog b/dev-libs/beecrypt/ChangeLog
index a0b9e73fbc77..223b90a468eb 100644
--- a/dev-libs/beecrypt/ChangeLog
+++ b/dev-libs/beecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/beecrypt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.37 2006/10/24 19:36:34 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.38 2006/10/24 20:40:11 alonbl Exp $
+
+ 24 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ files/beecrypt-4.1.2-build.patch:
+ Fixed athlon64 asm (again), closes again bug#152575
24 Oct 2006; Sandro Bonazzola <sanchan@gentoo.org>
files/beecrypt-4.1.2-build.patch:
diff --git a/dev-libs/beecrypt/files/beecrypt-4.1.2-build.patch b/dev-libs/beecrypt/files/beecrypt-4.1.2-build.patch
index 144134bd11ae..ea34a7d4f7e0 100644
--- a/dev-libs/beecrypt/files/beecrypt-4.1.2-build.patch
+++ b/dev-libs/beecrypt/files/beecrypt-4.1.2-build.patch
@@ -1,6 +1,6 @@
diff -urNp beecrypt-4.1.2.org/acinclude.m4 beecrypt-4.1.2/acinclude.m4
--- beecrypt-4.1.2.org/acinclude.m4 2004-12-19 22:16:35.000000000 +0200
-+++ beecrypt-4.1.2/acinclude.m4 2006-10-23 23:28:38.000000000 +0200
++++ beecrypt-4.1.2/acinclude.m4 2006-10-24 22:23:27.000000000 +0200
@@ -16,7 +16,7 @@ AC_DEFUN([BEECRYPT_WITH_CPU],[
i[[3456]]86)
case $withval in
@@ -32,16 +32,28 @@ diff -urNp beecrypt-4.1.2.org/acinclude.m4 beecrypt-4.1.2/acinclude.m4
],[
CFLAGS=$CFLAGS_save
CXXFLAGS=$CXXFLAGS_save
-@@ -1126,6 +1127,8 @@ AC_DEFUN([BEECRYPT_ASM_SOURCES],[
+@@ -1126,6 +1127,11 @@ AC_DEFUN([BEECRYPT_ASM_SOURCES],[
m4 $srcdir/gas/mpopt.alpha.m4 > mpopt.s
])
;;
-+ athlon64 | athlon-fx | em64t | k8)
++ x86_64 | athlon64 | athlon-fx | em64t | k8)
++ AC_CONFIG_COMMANDS([mpopt.x86_64],[
++ m4 $srcdir/gas/mpopt.x86_64.m4 > mpopt.s
++ ])
+ ;;
athlon* | i[[3456]]86 | pentium*)
AC_CONFIG_COMMANDS([aesopt.x86],[
m4 $srcdir/gas/aesopt.x86.m4 > aesopt.s
-@@ -1184,6 +1187,8 @@ AC_DEFUN([BEECRYPT_ASM_SOURCES],[
+@@ -1175,15 +1181,12 @@ AC_DEFUN([BEECRYPT_ASM_SOURCES],[
+ m4 $srcdir/gas/mpopt.sparcv8plus.m4 > mpopt.s
+ ])
+ ;;
+- x86_64)
+- AC_CONFIG_COMMANDS([mpopt.x86_64],[
+- m4 $srcdir/gas/mpopt.x86_64.m4 > mpopt.s
+- ])
+- ;;
+ esac
if test "$ac_with_arch" = yes; then
# Code is i586-specific!
case $bc_target_arch in
@@ -52,7 +64,7 @@ diff -urNp beecrypt-4.1.2.org/acinclude.m4 beecrypt-4.1.2/acinclude.m4
m4 $srcdir/gas/blowfishopt.i586.m4 > blowfishopt.s
diff -urNp beecrypt-4.1.2.org/configure.ac beecrypt-4.1.2/configure.ac
--- beecrypt-4.1.2.org/configure.ac 2004-12-21 13:37:56.000000000 +0200
-+++ beecrypt-4.1.2/configure.ac 2006-10-23 22:04:30.000000000 +0200
++++ beecrypt-4.1.2/configure.ac 2006-10-24 22:18:01.000000000 +0200
@@ -501,9 +501,11 @@ if test "$ac_enable_debug" != yes; then
arm*)
CPPFLAGS="$CPPFLAGS -DOPTIMIZE_ARM"
@@ -123,7 +135,7 @@ diff -urNp beecrypt-4.1.2.org/configure.ac beecrypt-4.1.2/configure.ac
diff -urNp beecrypt-4.1.2.org/gas/x86.m4 beecrypt-4.1.2/gas/x86.m4
--- beecrypt-4.1.2.org/gas/x86.m4 2004-06-13 14:37:28.000000000 +0300
-+++ beecrypt-4.1.2/gas/x86.m4 2006-10-23 22:05:14.000000000 +0200
++++ beecrypt-4.1.2/gas/x86.m4 2006-10-24 22:18:01.000000000 +0200
@@ -48,3 +48,25 @@ define(USE_MMX)
define(USE_SSE)
define(USE_SSE2)