summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog6
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.26-disable_static_modules.patch12
-rw-r--r--dev-libs/libxslt/libxslt-1.1.26.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index b29196842b57..0221f8e52e9c 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libxslt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.206 2011/02/12 15:16:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.207 2011/02/26 17:31:21 arfrever Exp $
+
+ 26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libxslt-1.1.26.ebuild, +files/libxslt-1.1.26-disable_static_modules.patch:
+ Don't install .a files in Python site-packages directories.
12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
libxslt-1.1.26.ebuild:
diff --git a/dev-libs/libxslt/files/libxslt-1.1.26-disable_static_modules.patch b/dev-libs/libxslt/files/libxslt-1.1.26-disable_static_modules.patch
new file mode 100644
index 000000000000..fad067ff4348
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.26-disable_static_modules.patch
@@ -0,0 +1,12 @@
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -24,7 +24,8 @@
+ libxslt-python-api.xml \
+ $(DOCS)
+
+-libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
++libxsltmod_la_CPPFLAGS = -shared
++libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -module -avoid-version -shared
+
+ if WITH_PYTHON
+ mylibs = \
diff --git a/dev-libs/libxslt/libxslt-1.1.26.ebuild b/dev-libs/libxslt/libxslt-1.1.26.ebuild
index 86f97a1c3b5f..f8821ed22d47 100644
--- a/dev-libs/libxslt/libxslt-1.1.26.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.26.ebuild,v 1.15 2011/02/12 15:16:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.26.ebuild,v 1.16 2011/02/26 17:31:21 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="python? 2"
@@ -30,7 +30,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/libxslt.m4-${P}.patch \
"${FILESDIR}"/${PN}-1.1.23-parallel-install.patch \
- "${FILESDIR}"/${P}-undefined.patch
+ "${FILESDIR}"/${P}-undefined.patch \
+ "${FILESDIR}"/${P}-disable_static_modules.patch
# Python bindings are built/tested/installed manually.
sed -e "s/@PYTHON_SUBDIR@//" -i Makefile.am || die "sed failed"