summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sha/ChangeLog5
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-ml/ocaml-sha/ChangeLog b/dev-ml/ocaml-sha/ChangeLog
index 4663e1bad46b..fac6de1331ff 100644
--- a/dev-ml/ocaml-sha/ChangeLog
+++ b/dev-ml/ocaml-sha/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocaml-sha
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ChangeLog,v 1.3 2013/08/19 13:40:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ChangeLog,v 1.4 2013/08/19 13:41:50 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocaml-sha-1.8.ebuild:
+ eapi5, define subslot and add := dep on ocaml packages
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> -ocaml-sha-1.7.ebuild:
remove old
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
index 637cbba1406c..16fd18258bda 100644
--- a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild,v 1.1 2012/10/30 11:42:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild,v 1.2 2013/08/19 13:41:50 aballier Exp $
-EAPI=4
+EAPI=5
inherit findlib vcs-snapshot
@@ -11,15 +11,15 @@ HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
SRC_URI="http://nodeload.github.com/vincenthz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
-DEPEND=">=dev-lang/ocaml-3.12[ocamlopt]"
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
RDEPEND="${DEPEND}"
src_compile() {
- emake -j1 || die
+ emake -j1
}
src_install() {