summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/jpgraph/ChangeLog5
-rw-r--r--dev-php5/jpgraph/files/digest-jpgraph-2.1.43
-rw-r--r--dev-php5/jpgraph/jpgraph-2.1.4.ebuild82
3 files changed, 4 insertions, 86 deletions
diff --git a/dev-php5/jpgraph/ChangeLog b/dev-php5/jpgraph/ChangeLog
index e2db30f6ddaf..76630a5b359f 100644
--- a/dev-php5/jpgraph/ChangeLog
+++ b/dev-php5/jpgraph/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php5/jpgraph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.20 2007/08/31 09:38:43 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.21 2007/09/06 16:03:57 jokey Exp $
+
+ 06 Sep 2007; Markus Ullmann <jokey@gentoo.org> -jpgraph-2.1.4.ebuild:
+ Cleanup
*jpgraph-2.2 (31 Aug 2007)
diff --git a/dev-php5/jpgraph/files/digest-jpgraph-2.1.4 b/dev-php5/jpgraph/files/digest-jpgraph-2.1.4
deleted file mode 100644
index 5322f357aa72..000000000000
--- a/dev-php5/jpgraph/files/digest-jpgraph-2.1.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2146fa93269cf4203e26296fb04167f3 jpgraph-2.1.4.tar.gz 4480770
-RMD160 ebc554950310083c35e347c9fb746b130181bf8b jpgraph-2.1.4.tar.gz 4480770
-SHA256 26bbed9eb07a411d9388b6be5813054b21214f279178dba28ae4337d43707da9 jpgraph-2.1.4.tar.gz 4480770
diff --git a/dev-php5/jpgraph/jpgraph-2.1.4.ebuild b/dev-php5/jpgraph/jpgraph-2.1.4.ebuild
deleted file mode 100644
index 95f5c70fb654..000000000000
--- a/dev-php5/jpgraph/jpgraph-2.1.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/jpgraph-2.1.4.ebuild,v 1.2 2007/07/29 16:54:25 phreak Exp $
-
-inherit php-lib-r1
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-
-DESCRIPTION="Fully OO graph drawing library for PHP."
-HOMEPAGE="http://www.aditus.nu/jpgraph/"
-SRC_URI="http://hem.bredband.net/jpgraph2/${P}.tar.gz"
-LICENSE="QPL-1.0"
-SLOT="0"
-IUSE="truetype"
-
-DEPEND=""
-RDEPEND="truetype? ( media-fonts/corefonts )"
-
-need_php_by_category
-
-[[ -z "${JPGRAPH_CACHEDIR}" ]] && JPGRAPH_CACHEDIR="/var/cache/jpgraph-php5/"
-
-pkg_setup() {
- has_php
-
- # we need the PHP GD functionality
- require_gd
-
- # check to wich user:group the cache dir will go
- if has_version "www-servers/apache" ; then
- HTTPD_USER="apache"
- HTTPD_GROUP="apache"
- einfo "Configuring ${JPGRAPH_CACHEDIR} for Apache."
- else
- HTTPD_USER="root"
- HTTPD_GROUP="root"
- ewarn "No Apache webserver detected - ${JPGRAPH_CACHEDIR} will be"
- ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
- fi
-}
-
-src_install() {
- # some patches to adapt the config to Gentoo
- einfo "Patching jpg-config.inc.php"
-
- # patch 1:
- # make jpgraph use the correct group for file permissions
-
- sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc.php
-
- # patch 2:
- # make jpgraph use the correct directory for caching
-
- sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHEDIR}\");|" src/jpg-config.inc.php
-
- # patch 3:
- # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
-
- if use truetype ; then
- sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"/usr/share/fonts/corefonts/\");|" src/jpg-config.inc.php
- fi
-
- # patch 4:
- # disable READ_CACHE in jpgraph
-
- sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc.php
-
- # install php files
- einfo "Building list of files to install"
- php-lib-r1_src_install src `cd src ; find . -type f -print`
-
- # install documentation
- einfo "Installing documentation"
- dodoc-php README QPL.txt
- dohtml -r docs/*
-
- # setup the cache dir
- einfo "Setting up the cache dir"
- keepdir "${JPGRAPH_CACHEDIR}"
- fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHEDIR}"
- fperms 750 "${JPGRAPH_CACHEDIR}"
-}