summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/geoip-python/geoip-python-1.3.1.ebuild')
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/geoip-python/geoip-python-1.3.1.ebuild b/dev-python/geoip-python/geoip-python-1.3.1.ebuild
new file mode 100644
index 000000000000..fc781125a53d
--- /dev/null
+++ b/dev-python/geoip-python/geoip-python-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.3.1.ebuild,v 1.1 2014/07/18 05:00:36 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="geoip-api-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GeoIP"
+HOMEPAGE="https://github.com/maxmind/geoip-api-python"
+SRC_URI="https://github.com/maxmind/geoip-api-python/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-libs/geoip-1.4.8"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.rst ChangeLog.md )
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}