summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rsa/rsa-3.0.1.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-3.0.1.ebuild b/dev-python/rsa/rsa-3.0.1.ebuild
new file mode 100644
index 000000000000..f8c5ca727fd9
--- /dev/null
+++ b/dev-python/rsa/rsa-3.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/rsa-3.0.1.ebuild,v 1.1 2012/05/08 22:35:40 floppym Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa http://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyasn1-0.0.13
+ >=dev-python/setuptools-0.6.10"
+DEPEND="${RDEPEND}
+ app-arch/unzip"