summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/opengfx/opengfx-0.2.3.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.2.3.ebuild b/games-misc/opengfx/opengfx-0.2.3.ebuild
new file mode 100644
index 000000000000..cf7263ff9491
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.2.3.ebuild,v 1.1 2010/04/08 23:19:45 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-source
+
+DEPEND="games-util/nforenum
+ games-util/grfcodec"
+RDEPEND=""
+
+src_compile() {
+ emake bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg || die
+ dodoc docs/{changelog.txt,readme.txt} || die
+ prepgamesdirs
+}