summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/pmars-sdl/ChangeLog7
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/games-simulation/pmars-sdl/ChangeLog b/games-simulation/pmars-sdl/ChangeLog
index ba6f82a36941..6627980b32e6 100644
--- a/games-simulation/pmars-sdl/ChangeLog
+++ b/games-simulation/pmars-sdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/pmars-sdl
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/ChangeLog,v 1.8 2008/11/18 20:23:12 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/ChangeLog,v 1.9 2010/10/13 07:22:51 tupone Exp $
+
+ 13 Oct 2010; Tupone Alfredo <tupone@gentoo.org> pmars-sdl-0.9.2e.ebuild:
+ Respect LDFLAGS. Bug #335540 by flameeyes@gentoo.org
18 Nov 2008; Michael Sterrett <mr_bones_@gentoo.org>
pmars-sdl-0.9.2e.ebuild:
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
index 93f48322abc1..14dfbee52049 100644
--- a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild,v 1.11 2008/11/18 20:23:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild,v 1.12 2010/10/13 07:22:51 tupone Exp $
inherit toolchain-funcs games
@@ -17,10 +17,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE="sdl X svga"
-DEPEND="sdl? ( x11-libs/libX11 media-libs/libsdl )
+RDEPEND="sdl? ( x11-libs/libX11 media-libs/libsdl )
X? ( x11-libs/libX11 )
svga? ( media-libs/svgalib )
!sdl? ( !X? ( !svga? ( sys-libs/ncurses ) ) )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -63,7 +64,7 @@ src_compile() {
echo
einfo "linking with LIB: ${LIB}"
- $(tc-getCC) *.o ${LIB} -o ${MY_PN} || die
+ $(tc-getCC) ${LDFLAGS} *.o ${LIB} -o ${MY_PN} || die
}
src_install() {