summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/searchtool/searchtool-0.4.4.ebuild')
-rw-r--r--games-util/searchtool/searchtool-0.4.4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-util/searchtool/searchtool-0.4.4.ebuild b/games-util/searchtool/searchtool-0.4.4.ebuild
index 09a85041c1ba..c0f37aa04b85 100644
--- a/games-util/searchtool/searchtool-0.4.4.ebuild
+++ b/games-util/searchtool/searchtool-0.4.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/searchtool/searchtool-0.4.4.ebuild,v 1.1 2003/09/10 18:53:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/searchtool/searchtool-0.4.4.ebuild,v 1.2 2004/04/18 06:37:08 mr_bones_ Exp $
inherit games
@@ -11,14 +11,15 @@ SRC_URI="mirror://sourceforge/searchtool/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="dev-java/ant"
RDEPEND="virtual/jre"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_compile() {
- ant || die
+ ant || die "ant failed"
sed \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
-e "s:GENTOO_P:${P}:" \
@@ -26,9 +27,9 @@ src_compile() {
}
src_install() {
- insinto ${GAMES_DATADIR}/${PN}
+ dogamesbin searchtool || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
doins ${P}.jar
- dogamesbin searchtool
dodoc README
prepgamesdirs
}