summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild')
-rw-r--r--media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild b/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild
new file mode 100644
index 000000000000..9ac017a0340c
--- /dev/null
+++ b/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild,v 1.1 2003/07/15 09:48:50 usata Exp $
+
+IUSE=""
+
+DESCRIPTION="Image viewer for w3m under frame buffer environment"
+SRC_URI="http://homepage3.nifty.com/slokar/fb/${P}.tar.gz"
+HOMEPAGE="http://homepage3.nifty.com/slokar/fb/w3mimg.html"
+
+SLOT="0"
+LICENSE="w3m BSD"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/stimg-0.1.0
+ virtual/textbrowser"
+
+src_compile() {
+ emake CC="${CC}" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ if [ -d /usr/lib/w3m ] ; then
+ exeinto /usr/lib/w3m
+ doexe w3mimgdisplayfb
+ fi
+ if [ -d /usr/lib/w3m-m17n ] ; then
+ exeinto /usr/lib/w3m-m17n
+ doexe w3mimgdisplayfb
+ fi
+
+ dodoc COPYING readme.txt
+}